freebsd-ports/games/warmux/files/patch-lib-warmux-action-action.cpp
Marcus von Appen fbd0197639 - Update devel/sdl12 to 1.2.15
- Update audio/sdl_mixer to 1.2.15
- Update graphics/sdl_image to 1.2.12
- Update graphics/sdl_ttf to 2.0.11
- Update graphics/sdl_gfx to 2.0.23
- Update net/sdl_net to 1.2.8
- Bump PORTREVISIONs on ports that depend on one or more packages due to
ABI and shared library version changes
- Update Mk/bsd.sdl.mk accordingly for the new shared library versions

Tested by:	exp-run by pav
2012-02-18 10:18:33 +00:00

11 lines
409 B
C++

--- lib/warmux/action/action.cpp.orig 2012-02-13 22:38:00.000000000 +0100
+++ lib/warmux/action/action.cpp 2012-02-13 22:37:45.000000000 +0100
@@ -85,7 +85,7 @@
{
m_creator = _creator;
- m_header.len = SDLNet_Read32(buffer);
+ m_header.len = SDLNet_Read32((Uint32*)buffer);
ASSERT(m_header.len >= sizeof(Header));
buffer += 4;
// All of the following could be skipped for the actions we now,