freebsd-ports/net/spread/files/patch-FreeBSD_makefile
Pete Fritchman 1825eac2c9 - update to 3.16.1
- pass maintainership to submitter
- make the java dependency more flexible
- get rid of NO_PACKAGE and add a pkg-install script to create the
  user/group needed
- use DOCSDIR instead of the port-specific DOCDIR
- set PKGMESSAGE to the license file
- sort pkg-plist
- respect PREFIX

PR:		35407
Submitted by:	Joshua Goodall <joshua@roughtrade.net> (new maintainer)
2002-03-02 16:59:30 +00:00

36 lines
1.1 KiB
Text

--- FreeBSD_makefile.orig Wed Aug 22 00:28:21 2001
+++ FreeBSD_makefile Thu Feb 28 23:27:26 2002
@@ -1,4 +1,3 @@
-CC=gcc
MAKEFILE=FreeBSD_makefile
YACC = bison -y
LEX = flex
@@ -8,8 +7,8 @@
#SRCDIRS= dir1 dir2
#INCL=$(SRCDIRS:%=-I%)
#CFLAGS = -O does not always work on BSDI pc
-CFLAGS = -ansi -c -Wall -O3
-TCFLAGS = $(CFLAGS) -pthread
+CFLAGS += -ansi -c
+TCFLAGS = $(CFLAGS) $(PTHREAD_LIBS)
COBJS = lex.yy.o y.tab.o configuration.o skiplist.o acm.o
OBJS = alarm.o events.o memory.o membership.o data_link.o network.o status.o log.o flow_control.o message.o acp-permit.o auth-null.o auth-ip.o
@@ -30,7 +29,7 @@
$(CC) -o spuser user.o libsp.a
sptuser : user.to libtsp.a
- $(CC) -pthread -o sptuser user.to libtsp.a
+ $(CC) $(PTHREAD_LIBS) -o sptuser user.to libtsp.a
simple_user : simple_user.o libsp.a
$(CC) -o simple_user simple_user.o libsp.a
@@ -78,7 +77,7 @@
$(CC) $(TCFLAGS) -fPIC -D_REENTRANT $*.c -o $*.tlo
.c.to:
- $(CC) $(TCFLAGS) -D_THREAD_SAFE -D_REENTRANT $*.c -o $*.to
+ $(CC) $(TCFLAGS) $(PTHREAD_CFLAGS) -D_REENTRANT $*.c -o $*.to
depend:
cp $(MAKEFILE) $(MAKEFILE).bak \