c90874ad51
- New program ssh-keysign - New manpages for ssh_config and sshd_config - Merge Pathes to new files - Fix GCC problem with unsupported __func__ in older Releases
41 lines
955 B
Text
41 lines
955 B
Text
--- ssh/Makefile.orig Thu Jun 20 21:56:07 2002
|
|
+++ ssh/Makefile Fri Jun 21 22:59:47 2002
|
|
@@ -7,8 +7,9 @@
|
|
|
|
#BINMODE?=4555
|
|
|
|
-BINDIR= /usr/bin
|
|
-MAN= ssh.1 ssh_config.5
|
|
+BINDIR= /bin
|
|
+MAN1= ssh.1
|
|
+MAN5= ssh_config.5
|
|
LINKS= ${BINDIR}/ssh ${BINDIR}/slogin
|
|
MLINKS= ssh.1 slogin.1
|
|
|
|
@@ -16,6 +17,7 @@
|
|
sshconnect.c sshconnect1.c sshconnect2.c
|
|
|
|
.include <bsd.own.mk> # for AFS
|
|
+.include "../Makefile.inc"
|
|
|
|
.if (${KERBEROS5:L} == "yes")
|
|
CFLAGS+= -DKRB5 -I${DESTDIR}/usr/include/kerberosV
|
|
@@ -24,8 +26,8 @@
|
|
.endif # KERBEROS5
|
|
|
|
.if (${KERBEROS:L} == "yes")
|
|
-CFLAGS+= -DKRB4 -I${DESTDIR}/usr/include/kerberosIV
|
|
-LDADD+= -lkrb
|
|
+CFLAGS+= -DKRB4 -I/usr/include/kerberosIV
|
|
+LDADD+= -lkrb -lcom_err
|
|
DPADD+= ${LIBKRB}
|
|
.if (${AFS:L} == "yes")
|
|
CFLAGS+= -DAFS
|
|
@@ -36,5 +38,5 @@
|
|
|
|
.include <bsd.prog.mk>
|
|
|
|
-LDADD+= -lcrypto -lz -ldes
|
|
-DPADD+= ${LIBCRYPTO} ${LIBZ} ${LIBDES}
|
|
+LDADD+= ${CRYPTOLIBS} -lcrypt -lutil -lz
|
|
+DPADD+= ${LIBCRYPTO} ${LIBUTIL} ${LIBZ}
|