- Update to 1.0.18 and pkg-plist accordingly - Add LICENSE (BSD3CLAUSE) and LICENSE_FILE - Add TEST_DEPENDS and regression-test target - Perl is not required, remove USE_PERL and from USES - Split LDFLAGS from CONFIGURE_ENV, they're already set there - Add libmemcachedprotocol to CONFIGURE_ARGS (Now default: off) - Add OPTIONS for hash functions, debug and dtrace - pkg-descr: Update WWW: URL - Add patches for: * alloca.h include not found on FreeBSD * cinttypes include location * clang compatibility - Strip shared libraries manually since upstream install-strip target is fail Changes: https://launchpad.net/libmemcached/+announcements [1] https://bugs.launchpad.net/libmemcached/+bug/1245562 [2] https://bugs.launchpad.net/libmemcached/+bug/1400560 Approved by: Mikhail Tsatsenko <m.tsatsenko@gmail.com> (maintainer, via email)
38 lines
905 B
Text
38 lines
905 B
Text
diff --git a/clients/memflush.cc b/clients/memflush.cc
|
|
index 8bd0dbf..cdba743 100644
|
|
--- clients/memflush.cc
|
|
+++ clients/memflush.cc
|
|
@@ -39,7 +39,7 @@ int main(int argc, char *argv[])
|
|
{
|
|
options_parse(argc, argv);
|
|
|
|
- if (opt_servers == false)
|
|
+ if (opt_servers == NULL)
|
|
{
|
|
char *temp;
|
|
|
|
@@ -48,7 +48,7 @@ int main(int argc, char *argv[])
|
|
opt_servers= strdup(temp);
|
|
}
|
|
|
|
- if (opt_servers == false)
|
|
+ if (opt_servers == NULL)
|
|
{
|
|
std::cerr << "No Servers provided" << std::endl;
|
|
exit(EXIT_FAILURE);
|
|
diff --git a/libmemcached-1.0/memcached.h b/libmemcached-1.0/memcached.h
|
|
index bc16e73..dcee395 100644
|
|
--- libmemcached-1.0/memcached.h
|
|
+++ libmemcached-1.0/memcached.h
|
|
@@ -43,7 +43,11 @@
|
|
#endif
|
|
|
|
#ifdef __cplusplus
|
|
+#ifdef _LIBCPP_VERSION
|
|
# include <cinttypes>
|
|
+#else
|
|
+# include <tr1/cinttypes>
|
|
+#endif
|
|
# include <cstddef>
|
|
# include <cstdlib>
|
|
#else
|