- Update to 1.0.18 and pkg-plist accordingly - Add LICENSE (BSD3CLAUSE) and LICENSE_FILE - Add TEST_DEPENDS and regression-test target - Perl is not required, remove USE_PERL and from USES - Split LDFLAGS from CONFIGURE_ENV, they're already set there - Add libmemcachedprotocol to CONFIGURE_ARGS (Now default: off) - Add OPTIONS for hash functions, debug and dtrace - pkg-descr: Update WWW: URL - Add patches for: * alloca.h include not found on FreeBSD * cinttypes include location * clang compatibility - Strip shared libraries manually since upstream install-strip target is fail Changes: https://launchpad.net/libmemcached/+announcements [1] https://bugs.launchpad.net/libmemcached/+bug/1245562 [2] https://bugs.launchpad.net/libmemcached/+bug/1400560 Approved by: Mikhail Tsatsenko <m.tsatsenko@gmail.com> (maintainer, via email)
13 lines
265 B
C
13 lines
265 B
C
--- libtest/lite.h.orig 2014-12-09 03:34:21 UTC
|
|
+++ libtest/lite.h
|
|
@@ -54,8 +54,10 @@
|
|
#if defined(WIN32)
|
|
# include <malloc.h>
|
|
#else
|
|
+#ifdef HAVE_ALLOCA_H
|
|
# include <alloca.h>
|
|
#endif
|
|
+#endif
|
|
|
|
#ifndef __PRETTY_FUNCTION__
|
|
# define __PRETTY_FUNCTION__ __func__
|