gstreamer plugin (52 new ports). - Chase changes to ports that used USE_GNOME=gstreamerplugisn to use new USE_GSTREAMER= macro, Bump PORTREVISION's -- Examples of new USE_GSTREAMER macro: USE_GSTREAMER= dvd lame flac .include <bsd.port.mk> If you want to use USE_GSTREAMER after <bsd.port.pre.mk> you must follow one of the examples listed below WANT_GSTREAMER= yes .include <bsd.port.pre.mk> .if defined(WITH_VORBIS) USE_GSTREAMER+= vorbis .endif or USE_GSTREAMER= yes .include <bsd.port.pre.mk> .if defined(WITH_FAAD) USE_GSTREAMER+= faad .endif Note: USE_GSTREAMER=yes will always add a dependency to ports/multimedia/gstreamer-plugins -- Thanks to krion for runing this on pointyhat Thanks to kwm for helping with this, and many bug fixes , and updates.
23 lines
1,020 B
Text
23 lines
1,020 B
Text
--- ext/sdl/Makefile.in.orig Mon Oct 4 00:56:57 2004
|
|
+++ ext/sdl/Makefile.in Mon Oct 4 00:57:47 2004
|
|
@@ -76,8 +76,7 @@
|
|
pluginLTLIBRARIES_INSTALL = $(INSTALL)
|
|
LTLIBRARIES = $(plugin_LTLIBRARIES)
|
|
am__DEPENDENCIES_1 =
|
|
-libgstsdlvideosink_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
|
|
- $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la
|
|
+libgstsdlvideosink_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
|
|
am_libgstsdlvideosink_la_OBJECTS = \
|
|
libgstsdlvideosink_la-sdlvideosink.lo
|
|
libgstsdlvideosink_la_OBJECTS = $(am_libgstsdlvideosink_la_OBJECTS)
|
|
@@ -617,9 +616,7 @@
|
|
plugin_LTLIBRARIES = libgstsdlvideosink.la
|
|
libgstsdlvideosink_la_SOURCES = sdlvideosink.c
|
|
libgstsdlvideosink_la_CFLAGS = $(GST_CFLAGS) $(SDL_CFLAGS)
|
|
-libgstsdlvideosink_la_LIBADD = $(SDL_LIBS) \
|
|
- $(top_builddir)/gst-libs/gst/libgstinterfaces-@GST_MAJORMINOR@.la
|
|
-
|
|
+libgstsdlvideosink_la_LIBADD = $(SDL_LIBS) -lgstinterfaces-%%VERSION%%
|
|
libgstsdlvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
|
|
noinst_HEADERS = sdlvideosink.h
|
|
all: all-am
|