freebsd-ports/devel/automoc4/files/patch-CMakeLists.txt
Mark Linimon 0570a13938 Work around the "automoc hangs forever while building kde" problem.
Requested by:	rakuco
Reviewed by:	swills, pav, linimon
2011-12-27 22:11:00 +00:00

13 lines
593 B
Text

--- CMakeLists.txt.orig Sun Dec 25 15:35:23 2011
+++ CMakeLists.txt Sun Dec 25 15:35:40 2011
@@ -21,7 +21,9 @@
set_target_properties(automoc4 PROPERTIES SKIP_BUILD_RPATH FALSE
INSTALL_RPATH_USE_LINK_PATH TRUE )
-target_link_libraries(automoc4 ${QT_QTCORE_LIBRARY})
+find_package(Threads)
+target_link_libraries(automoc4 ${QT_QTCORE_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
+
install(TARGETS automoc4 DESTINATION bin)
install(FILES Automoc4Config.cmake Automoc4Version.cmake automoc4.files.in DESTINATION lib${LIB_SUFFIX}/automoc4)