freebsd-ports/sysutils/bareos17-server/files/patch-src-plugins-filed_Makefile.in
Jose Alonso Cardenas Marquez f91e5463a5 - Copy bareos-* ports to bareos17-* ports. bareos-* ports will be updated to
latest version
- Fix bareos17-server build [1]
- Fix installation of sample files
- Bump PORTREVISION

PR:		230456 237165
Reported by:	ohartmann at walstatt.org [1], okrg at ukr.net [1]
2019-05-09 18:04:39 +00:00

21 lines
1 KiB
Text

--- src/plugins/filed/Makefile.in 2018-05-17 15:34:21.796332000 -0500
+++ src/plugins/filed/Makefile.in 2018-05-17 15:35:50.843157000 -0500
@@ -93,7 +93,8 @@
install: all
$(MKDIR) $(DESTDIR)$(plugindir)
- $(MKDIR) ${DESTDIR}${configtemplatedir}/bareos-dir.d/
+ $(MKDIR) ${DESTDIR}${configtemplatedir}/bareos-dir.d/fileset
+ $(MKDIR) ${DESTDIR}${configtemplatedir}/bareos-dir.d/job
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) bpipe-fd.la $(DESTDIR)$(plugindir)
$(RMF) $(DESTDIR)$(plugindir)/bpipe-fd.la
if test "x$(BUILD_PLUGINS)" != "x" ; then \
@@ -111,7 +112,7 @@
$(CP) *.py *.py.template $(DESTDIR)$(plugindir); \
for i in `find python-ldap-conf.d/ \( -name "*.conf" -o -name "*.conf.example" \) -print | cut -d'/' -f2-`; do \
$(MKDIR) `dirname ${DESTDIR}${configtemplatedir}/$$i`; \
- $(INSTALL_CONFIG) python-ldap-conf.d/$$i ${DESTDIR}${configtemplatedir}/$$i; \
+ $(INSTALL_CONFIG) python-ldap-conf.d/$$i ${DESTDIR}${confdir}/`echo $$i | sed -e 's|example|sample|g'`; \
done; \
fi; \
done;\