X11 and Linux framebuffer front-end for VDR. Plugin displays video and OSD in X/Xv/XvMC/VAAPI/VDPAU window, Linux framebuffer/DirectFB/vidixfb or DXR3 card. Support for local and remote frontends. Built-in image and media player supports playback of most known media files (avi/mp3/divx/jpeg/...), DVDs and radio/video streams (http, rtsp, ...) directly from VDR. FreeBSD Note: If you want to use VAAPI/VDPAU make sure the ffmpeg and libxine ports are (re)built with the corresponding knobs turned on! (make config in their port dirs.) WWW: http://sourceforge.net/projects/xineliboutput/
47 lines
1.5 KiB
Text
47 lines
1.5 KiB
Text
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -84,13 +84,8 @@ VDRINCDIR = /usr/local/include
|
|
### check for VDR
|
|
###
|
|
|
|
-ifeq ($(ARCH_APPLE_DARWIN), yes)
|
|
VDRVERSION = $(shell sed -ne '/define VDRVERSION/s/^.*"\(.*\)".*$$/\1/p' $(VDRDIR)/config.h)
|
|
APIVERSION = $(shell sed -ne '/define APIVERSION/s/^.*"\(.*\)".*$$/\1/p' $(VDRDIR)/config.h)
|
|
-else
|
|
- VDRVERSION = $(shell sed -ne '/define VDRVERSION/ { s/^.*"\(.*\)".*$$/\1/; p }' $(VDRDIR)/config.h)
|
|
- APIVERSION = $(shell sed -ne '/define APIVERSION/ { s/^.*"\(.*\)".*$$/\1/; p }' $(VDRDIR)/config.h)
|
|
-endif
|
|
|
|
VDR_TREE = no
|
|
ifeq ($(strip $(VDRVERSION)),)
|
|
@@ -199,6 +194,9 @@ endif
|
|
ifdef STARTUP_IMAGE_FILE
|
|
DEFINES += -DSTARTUP_IMAGE_FILE='"$(STARTUP_IMAGE_FILE)"'
|
|
endif
|
|
+ifdef LOCALBASE
|
|
+ DEFINES += -DLOCALBASE='"$(LOCALBASE)"'
|
|
+endif
|
|
|
|
|
|
###
|
|
@@ -410,7 +408,7 @@ ifeq ($(XINELIBOUTPUT_VDRPLUGIN), yes)
|
|
@echo Installing $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN)
|
|
@mkdir -p $(DESTDIR)$(LIBDIR)
|
|
@-rm -rf $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN)
|
|
- @$(INSTALL) -D -m 0755 $(VDRPLUGIN) $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN)
|
|
+ @$(INSTALL) -m 0755 $(VDRPLUGIN) $(DESTDIR)$(LIBDIR)/$(VDRPLUGIN)
|
|
endif
|
|
endif
|
|
ifeq ($(XINELIBOUTPUT_FB), yes)
|
|
@@ -441,6 +439,11 @@ ifeq ($(XINELIBOUTPUT_X11), yes)
|
|
endif
|
|
endif
|
|
endif
|
|
+ifeq ($(XINELIBOUTPUT_VDRPLUGIN), yes)
|
|
+ @$(INSTALL) -m 0755 $(LIBDIR)/$(VDRPLUGIN) $(DESTDIR)/${PREFIX}/lib/vdr
|
|
+ @$(INSTALL) -m 0755 $(LIBDIR)/$(VDRPLUGIN_SXFE) $(DESTDIR)/${PREFIX}/lib/vdr
|
|
+
|
|
+endif
|
|
|
|
dist: clean
|
|
@-rm -rf $(TMPDIR)/$(ARCHIVE)
|