freebsd-ports/www/flock/files/patch-security-coreconf-FreeBSD.mk
Peter Wemm 7059589bd6 Port to amd64 (note: needs ld-elf.so.1 bugfix to actually work)
I've taken a chance and split the sparc64 and alpha mega-diffs up because
sparc64 patched the result of alpha's patches, and amd64 needed to do the
same again - but it was sorted lexically before alpha/sparc64.  I've
grouped the xptcall patches together since they are standalone and split
up and merged the other infrastructure jumbo-patches.

I also attempted to sync up the nspr vs firebird diffs for sparc64 and
alpha because they disagreed.  HOWEVER... While this port 'depends'
on the nspr port, it doesn't actually *use* it.  It should probably
be removed from the LIB_DEPENDS list.

Note that the amd64 xptcall code came from SuSE via the mozilla bugzilla
database.
2003-12-13 21:35:43 +00:00

12 lines
242 B
Makefile

--- security/coreconf/FreeBSD.mk Thu Oct 16 23:03:47 2003
+++ security/coreconf/FreeBSD.mk Thu Oct 16 22:53:11 2003
@@ -44,5 +44,9 @@
CPU_ARCH = alpha
else
+ifeq ($(OS_TEST),amd64)
+CPU_ARCH = amd64
+else
CPU_ARCH = x86
+endif
endif