freebsd-ports/lang/python30/files/patch-setup.py
Hye-Shik Chang a8ff97aec3 Update to 2.4a3
PR:		71340
Submitted by:	Marcus Grando <marcus@corp.grupos.com.br>
2004-09-03 17:12:28 +00:00

21 lines
723 B
Python

--- setup.py.orig Tue Aug 31 10:37:25 2004
+++ setup.py Fri Sep 3 10:42:53 2004
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+disabled_module_list = ["_bsddb", "_tkinter", "gdbm", "mpz"]
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -1144,8 +1144,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install
- scripts = ['Tools/scripts/pydoc', 'Tools/scripts/idle',
- 'Lib/smtpd.py']
+ scripts = []
)
# --install-platlib