0e7d58890a
- Add kfreebsd >= 9.1 fix to boot a kernel directly w/o chainloading [2] - see also: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=699002 - Add zfs support including zfs feature flags, see: [3] http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-boot/grub/files/grub-2.00-zfs-feature-flag-support-r1.patch - Add FUSE support and knob. - Switch to USES=gmake . - Add LICENSE. - Fix build on head. - Mark MAKE_JOBS_UNSAFE: https://redports.org/~nox/20130803161801-34924-135687/grub2-2.00_1.log - Misc. other changes. - This version is now used successfully by the PCBSD folks so I thought it's finally time to commit it. :) PR: ports/170417 [1] Submitted by: Norihiko Murase <mur1080224@inter7.jp> [1] (original version of the update) Submitted by: Christian Mangin <christian.mangin@gmail.com> [1] Submitted by: Richard Yao <ryao@gentoo.org> [1] (additional contributors to the PR) Obtained from: grub2 upstream [2] Obtained from: gentoo [3]
35 lines
1.2 KiB
Text
35 lines
1.2 KiB
Text
--- configure.ac.orig
|
|
+++ configure.ac
|
|
@@ -1044,19 +1044,19 @@ fi
|
|
|
|
if test x"$libzfs_excuse" = x ; then
|
|
# Only check for system headers if libzfs support has not been disabled.
|
|
- AC_CHECK_HEADERS(libzfs.h libnvpair.h)
|
|
+ AC_CHECK_HEADERS(libzfs.h libnvpair.h, [], [], [typedef int boolean_t;])
|
|
fi
|
|
|
|
if test x"$libzfs_excuse" = x ; then
|
|
AC_CHECK_LIB([zfs], [libzfs_init],
|
|
[],
|
|
- [libzfs_excuse="need zfs library"])
|
|
+ [libzfs_excuse="need zfs library"], [-lavl -lnvpair -luutil -lm])
|
|
fi
|
|
|
|
if test x"$libzfs_excuse" = x ; then
|
|
AC_CHECK_LIB([nvpair], [nvlist_print],
|
|
[],
|
|
- [libzfs_excuse="need nvpair library"])
|
|
+ [libzfs_excuse="need nvpair library"], [-lavl -lnvpair -luutil -lm])
|
|
fi
|
|
|
|
if test x"$enable_libzfs" = xyes && test x"$libzfs_excuse" != x ; then
|
|
@@ -1069,6 +1069,9 @@ if test x"$libzfs_excuse" = x ; then
|
|
AC_DEFINE([HAVE_LIBZFS], [1],
|
|
[Define to 1 if you have the ZFS library.])
|
|
LIBNVPAIR="-lnvpair"
|
|
+ if test x$host_kernel = xkfreebsd; then
|
|
+ LIBNVPAIR="$LIBNVPAIR -lavl -luutil -lm"
|
|
+ fi
|
|
AC_DEFINE([HAVE_LIBNVPAIR], [1],
|
|
[Define to 1 if you have the NVPAIR library.])
|
|
fi
|