freebsd-ports/graphics/llpp/files/patch-misc_completions_mkcomp.sh
Kurt Jaeger 1c26dc30e0 New port: graphics/llpp
llpp is a graphical PDF viewer which aims to superficially resemble
less(1).

WWW: http://repo.or.cz/llpp.git/

PR:		206006
Submitted by:	Tobias Kortkamp <t@tobik.me>
2016-02-03 11:53:25 +00:00

18 lines
601 B
Bash

--- misc/completions/mkcomp.sh.orig 2015-10-13 20:12:27 UTC
+++ misc/completions/mkcomp.sh
@@ -7,7 +7,7 @@ parse_infile () {
# Output list of file extensions from all input files, one per line.
# Delete lines beginning with `#', empty lines, and strip leading and
# trailing whitespace.
- sed -f - <<EOF $@
+ gsed -f - <<EOF $@
/^#/d
/^[[:space:]]*$/d
s/^[[:space:]]+//g
@@ -43,5 +43,5 @@ if test "$(basename "$f")" = llppac; the
fi
re="$(print_regex llpp.in $llppac)"
-sed -e "s/@re@/$re/g" "$f.mk" > "$f"
+gsed -e "s/@re@/$re/g" "$f.mk" > "$f"
printf "wrote: %s\n" "$f"