freebsd-ports/games/scourge/files/patch-configure.in
Tobias C. Berner d30b474483 games/scourge: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config
wrapper) in the near future -- use pkg-config to gather the required
flags.

PR:             251512
2021-08-10 16:42:34 +02:00

25 lines
867 B
Text

--- configure.in.orig 2008-12-22 23:38:10 UTC
+++ configure.in
@@ -421,8 +421,8 @@ if test "$FREETYPE" = "no"; then
AC_MSG_ERROR(Cannot find freetype2: Is freetype-config in path?)
have_FREETYPE=no
else
- FREETYPE_CFLAGS=`freetype-config --cflags`
- FREETYPE_LIBS=`freetype-config --libs`
+ FREETYPE_CFLAGS=`pkg-config freetype2 --cflags`
+ FREETYPE_LIBS=`pkg-config freetype2 --libs`
have_FREETYPE=yes
fi
fi
@@ -491,7 +491,10 @@ if test "x$has_glx_get_proc" = "xyes" ; then
fi
dnl Check for glext.h
-AC_CHECK_HEADERS( "GL/glext.h", have_glext_h=yes, have_glext_h=no )
+dnl XXX: which requires GL/gl.h, and autoconf > 2.64 is barfing on this
+dnk XXX: use following check to cover the bases
+dnl AC_CHECK_HEADERS( "GL/glext.h", have_glext_h=yes, have_glext_h=no )
+have_glext_h=yes
if test "x$have_glext_h" = "xno" ; then
AC_MSG_ERROR([