freebsd-ports/devel/loki/files/patch-src-Makefile
Wen Heping 4b012c89ee - Update to 0.1.7
Added file(s):
- files/patch-Makefile.common
- files/patch-test_SingletonDll_Makefile

Removed file(s):
- files/patch-Makefile
- files/patch-include-loki-Threads.h
- files/patch-test-Makefile
- files/patch-test-SingletonDll-Makefile
- files/patch-test-SmartPtr-main.cpp

PR:		ports/144062
Submitted by:	"Charlie &" <snnn119@gmail.com> (maintainer)
Feature safe:	yes
2010-03-03 12:05:05 +00:00

14 lines
408 B
Text

$FreeBSD$
--- src/Makefile.orig
+++ src/Makefile
@@ -20,7 +20,7 @@
override LDFLAGS += --shared -Wl,-soname=$(SHARED_LIB_VERSIONED) -fPIC
LDLIBS := -lpthread
else
-ifeq ($(OS), GNU/kFreeBSD)
+ifeq ($(OS), $(filter $(OS),GNU/kFreeBSD FreeBSD))
SHARED_LIB_BASE := libloki.so
SHARED_LIB_VERSIONED := libloki.so.$(VERSION)
override LDFLAGS += --shared -Wl,-soname=$(SHARED_LIB_VERSIONED) -fPIC