freebsd-ports/security/clamav/files/patch-clamscan::Makefile.in
Alexander Leidinger 71b93e612e BEWARE: As rcoder(8) isn't present on FreeBSD 4 but clamd must be
be started before clamav-milter the startup-script for clamd
        must alphabetically arranged before the startup-script for
        clamav-milter. It was decided to use the clamd statup-scrtipt
        from security/clamav-devel (clamav-clamd.sh), so users running
        an older version of security/clamav have to change
        'clamd_enable="YES"' to 'clamav_clamd_enable="YES"' in
        /etc/rc.conf. On the other hand this changes makes it easier
        to switch between security/clamav and security/clamav-devel.

- Respect PTHREAD_CFLAGS.
- Use USE_LIBTOOL_VER=14 as the libtool shipping with clamav 0.65
  erroneously links against libc _and_ libc_r on FreeBSD 4.
- Don't link against libcipher on FreeBSD < 501100, clamav doesn't
  depend on it. The linker warnings suggesting that it is required
  were triggered by linking against both, libc and libc_r.
- Unconditionally depend on math/libgmp4. Otherwise, if libgmp4 is
  already installed on a FreeBSD 4-STABLE system compilation of
  security/clamav fails, as the headers of libgmp4 are used but the
  base libgmp is used for linking.
- Fix generation of clamav-milter.8 when building with WITH_MILTER
  (part of new files/patch-clamav-milter::Makefile.in).
- Don't USE_GETOPT_LONG when compiling with WITH_MILTER, clamav
  uses its own getopt_long() regardless if a devel/libgnugetopt is
  installed or the version in the base of FreeBSD 5 is present.
- Allow compilation of WITH_MILTER with mail/sendmail.
- Install a startup-script (taken from security/clamav-devel with some
  fixes in comments) for clamav-milter when compiled with WITH_MILTER.
- In pkg-descr remove the note that clamav-milter doesn't build on
  FreeBSD 4 with base gcc, it builds fine there. Mention that
  clamav-milter can be optionally used (taken from pkg-descr of
  security/clamav-devel).
- Fix compilation when an older version of security/clamav is installed.
  If there's an older version of libclamav installed clamav 0.65 will
  link against it instead of the newly built one. This is not a problem
  if the installed version is compatible with the new one as libclamav
  gets linked dynamically and the installed version will be replaced
  with the new one. However, if the older version is incompatible
  linking of clamav 0.65 fails. This problem was discovered by
  Jan-Peter Koopmann Jan-Peter.Koopmann@seceidos.de and the fix
  (most of the new patches in the files directory) confirmed working.
- In clamav-milter replace the path to the used sendmail executable with
  the location of the mailwrapper(8) (/usr/sbin/sendmail). Obtained
  from security/clamav-devel.

PR:		59948
Submitted by:	Marius Strobl <marius@alchemy.franken.de>
Approved by:	maintainer
2003-12-08 14:06:49 +00:00

20 lines
803 B
Text

--- clamscan/Makefile.in.orig Fri Nov 21 17:03:08 2003
+++ clamscan/Makefile.in Fri Nov 21 17:04:35 2003
@@ -163,7 +163,7 @@
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
- $(AM_LDFLAGS) $(LDFLAGS) -o $@
+ $(LIBS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
CFLAGS = @CFLAGS@
DIST_SOURCES = $(clamscan_SOURCES)
DIST_COMMON = Makefile.am Makefile.in
@@ -207,7 +207,7 @@
-test -z "$(bin_PROGRAMS)" || rm -f $(bin_PROGRAMS)
clamscan$(EXEEXT): $(clamscan_OBJECTS) $(clamscan_DEPENDENCIES)
@rm -f clamscan$(EXEEXT)
- $(LINK) $(clamscan_LDFLAGS) $(clamscan_OBJECTS) $(clamscan_LDADD) $(LIBS)
+ $(LINK) $(clamscan_LDFLAGS) $(clamscan_OBJECTS) $(clamscan_LDADD)
mostlyclean-compile:
-rm -f *.$(OBJEXT) core *.core