freebsd-ports/security/cyrus-sasl/files/patch-ah
Ade Lovett 636d1ebd70 Cyrus-SASL 1.5.24 sources changed on Aug 15th
-- changed a hard coded value to a variable.

Kerberos IV detection fails due to double check on krb_mk_priv
(with/without com_err), used cached value from first check for krb_mk_priv.

Added addtional pwcheck methods (MySQL & LDAP Authentication).

PR:		21383
Submitted by:	maintainer
2000-09-19 02:59:29 +00:00

9 lines
572 B
Text

--- lib/Makefile.am.orig Thu Jul 20 21:35:02 2000
+++ lib/Makefile.am Fri Sep 15 20:56:28 2000
@@ -53,5 +53,5 @@
EXTRA_libsasl_la_SOURCES = db_none.c db_ndbm.c db_gdbm.c db_berkeley.c db_testw32.c
libsasl_la_LDFLAGS = -version-info $(sasl_version)
libsasl_la_DEPENDENCIES = $(SASL_DB_BACKEND) @LTLIBOBJS@
-libsasl_la_LIBADD = @LTLIBOBJS@ $(SASL_DB_BACKEND) $(SASL_DB_LIB) $(SASL_DL_LIB) $(PLAIN_LIBS)
+libsasl_la_LIBADD = @LTLIBOBJS@ $(SASL_DB_BACKEND) $(SASL_DB_LIB) $(SASL_DL_LIB) $(PLAIN_LIBS) ${LIB_LDAP} ${LIB_MYSQL}
# PLAIN_LIBS are linked in for sasl_checkpass