freebsd-ports/print/sgf2tex/files/patch-aa
Hiroki Sato 51e5ceb0ad - Fix pkg-plist and bump PORTREVISION.
- Remove BROKEN line.
- Depend on print/teTeX-base instead of print/teTeX.
- Use etex(1) for typeset of manual.dvi.
- Invoke mktexlsr(1) after install and deinstall.

Approved by:	portmgr (krion)
2005-03-28 18:48:39 +00:00

57 lines
1.9 KiB
Text

--- Makefile.orig Mon Jun 18 13:04:35 2001
+++ Makefile Mon Mar 28 15:04:58 2005
@@ -14,12 +14,18 @@
# TEXHASH is MakeTeXls-R for WEB2C Unix distribution, texhash for TETEX, blank
# for NTEX.
-MFDIR=/usr/share/texmf/fonts/source/public/GOOE
-TFMDIR=/usr/share/texmf/fonts/tfm/public/GOOE
-TEXINPUTS=/usr/share/texmf/tex/GOOE
-MANDIR=/usr/man/man1/
-BINDIR=/usr/local/bin/
+MFDIR=${PREFIX}/share/texmf/fonts/source/public/GOOE
+TFMDIR=${PREFIX}/share/texmf/fonts/tfm/public/GOOE
+TEXINPUTS=${PREFIX}/share/texmf/tex/generic/GOOE
+MANDIR=${PREFIX}/man/man1/
+BINDIR=${PREFIX}/bin/
+.if exists(${LOCALBASE}/bin/MakeTeXls-R)
+TEXHASH=MakeTeXls-R
+.elif exists(${LOCALBASE}/bin/texhash)
TEXHASH=texhash
+.else
+TEXHASH=
+.endif
# PKFONTS may be left undefined for the initial installation. If you are
# reinstalling fonts for which you have made modifications to the metafont
@@ -45,21 +51,23 @@
.SUFFIXES : .mf .tfm .300pk .360pk .432pk .600pk .720pk .864pk .300gf .360gf .432gf .600gf .720gf .864gf
+all: sgfsplit manual.dvi
+
sgfsplit: sgfsplit.c
cc -g -o sgfsplit sgfsplit.c
manual.dvi: manual.tex
- tex manual
+ ${TEX_BIN} manual
install: sgfsplit
rm -f $(PKFONTS)
- install -m 0644 *.mf $(MFDIR)
- install -m 0644 *.tfm $(TFMDIR)
- install -m 0755 sgf2tex sgfsplit $(BINDIR)
- install -m 0644 sgf2tex.1 sgfsplit.1 $(MANDIR)
- install -m 0644 gooemacs.tex gotcmacs.tex $(TEXINPUTS)
+ mkdir -p $(MFDIR) && install -c -m 0644 *.mf $(MFDIR)
+ mkdir -p $(TFMDIR) && install -c -m 0644 *.tfm $(TFMDIR)
+ install -c -m 0755 sgf2tex sgfsplit $(BINDIR)
+ install -c -m 0644 sgf2tex.1 sgfsplit.1 $(MANDIR)
+ mkdir -p $(TEXINPUTS) && install -c -m 0644 gooemacs.tex gotcmacs.tex $(TEXINPUTS)
$(TEXHASH)
- tex manual
+ install -c -m 0644 manual.dvi ${TEXINPUTS}/manual.dvi
# The preferred method of installation is just to copy the metafont
# sources and tfm files into appropriated directories in MakeTeXPK's