freebsd-ports/devel/swarm/files/patch-src::tkobjc::Makefile.in
Edwin Groothuis 86b09615e6 idevel/swarm - undefined reference in libobjc.so
- make port regarding libobj.so (see PR)
	- make port BROKEN regarding graphics/hdf5
	- unbreak port regarding missing "'s (see BENTO)

PR:		ports/51484
Submitted by:	Horance Chou <horance@freedom.ie.cycu.edu.tw>
2003-10-10 13:26:50 +00:00

11 lines
618 B
Text

--- src/tkobjc/Makefile.in.orig Mon Apr 10 15:28:04 2000
+++ src/tkobjc/Makefile.in Fri Oct 10 06:06:05 2003
@@ -1270,7 +1270,7 @@
@CONSERVATIVE_OPTIMIZATION_TRUE@ $(OBJCCOMPILE) -O0 -c -o $@ $<
%_tcl.x: %.tcl
- (echo 'const char *$(notdir $(basename $<))_tcl = "' ; cat $< | sed -e 's/\\/\\\\/g' -e 's/"/\\"/g' ; echo '";' ) > $@
+ (echo 'const char *$(notdir $(basename $<))_tcl = "\\' ; cat $< | sed -e 's/\\/\\\\/g' -e 's/"/\\"\\\\/g' -e 's/$$/\\n\\/' ; echo '";' ) > $@
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.