freebsd-ports/comms/morse/files/patch-qso.d-Makefile
Alex Kozlov 6df25e8a32 Morse Classic is a generic morse-code practice utility
for Unix systems. A modified version of the program "QSO"
by Paul J. Drongowski is also included.

PR:	ports/166863
Submitted by:	Stephen Hurd <shurd@sasktel.net>
Approved by:	eadler (mentor)
2012-04-18 05:04:42 +00:00

17 lines
450 B
Text

--- qso.d/Makefile.orig 2010-10-12 22:11:39.000000000 -0700
+++ qso.d/Makefile 2012-04-12 10:23:28.000000000 -0700
@@ -1,4 +1,4 @@
-CFLAGS = -O3
+#CFLAGS = -O3
OBJECTS = QSO.o put_form.o make_fre.o grammar.o util.o init_str.o
INCLUDES = antenna.h callsign.h city.h cityh.h heights.h jobs.h misc.h \
@@ -7,7 +7,7 @@
all: QSO
QSO: $(OBJECTS)
- $(CC) -o $@ $(OBJECTS)
+ $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJECTS)
init_str.o: $(INCLUDES)