freebsd-ports/mail/dcc-dccd/files/patch-misc_Makefile.in
John Marino 9ace672370 mail/dcc-dccd: fix stage-qa issues
1) implements stripping of executable binaries
2) disables libedit detection and linking

dcc-dccd keeps trying to link to the base libedit instead of the
required ports version (when USES+=libedit is added).  For now, just
build without until somebody finds a way get libedit linkage correct.
This solves both issues seen with stage-qa

PR:		205191
Reported by:	Yuri (rawbw.com)
Utimate fix:	marino@
Approved by:	maintainer (conceptually)
2016-08-22 14:31:40 +00:00

11 lines
389 B
Text

--- misc/Makefile.in.orig 2014-08-06 14:43:42 UTC
+++ misc/Makefile.in
@@ -51,7 +51,7 @@ DCC_BINDIR=@installroot@@libexecdir@
@MAKE_INC2@
install:
- for NM in $(SSCRIPTS); do $(BININSTALL) $$NM $(DCC_BINDIR)/$$NM;done
+ for NM in $(SSCRIPTS); do $(BSD_INSTALL_SCRIPT) $$NM $(DCC_BINDIR)/$$NM;done
deinstall:
-if test -d $(DCC_BINDIR); then cd $(DCC_BINDIR); rm -f $(SSCRIPTS); fi