freebsd-ports/sysutils/k3b-kde4/files/patch-CMakeLists.txt
Max Brazhnikov 8162989ab7 sysutils/k3b-kde4:
- Update to 2.0.3
- Remove patches merged upstream, regenerate patches
- Add patch obtained from Gentoo to fix build with modern ffmpeg/libav

PR:		202561
Submitted by:	matthew@reztek.cz
2015-08-25 13:10:47 +00:00

15 lines
669 B
Text

--- CMakeLists.txt.orig 2014-11-04 18:43:47 UTC
+++ CMakeLists.txt
@@ -106,10 +106,10 @@ if(K3B_BUILD_FFMPEG_DECODER_PLUGIN)
include(CMakePushCheckState)
cmake_push_check_state()
- if(CMAKE_COMPILER_IS_GNUCC)
+ if(CMAKE_COMPILER_IS_GNUCC OR "${CMAKE_C_COMPILER_ID}" MATCHES "Clang")
# FindKDE4Internal.cmake screws things up
set(CMAKE_REQUIRED_FLAGS ${CMAKE_REQUIRED_FLAGS} -std=c99)
- endif(CMAKE_COMPILER_IS_GNUCC)
+ endif(CMAKE_COMPILER_IS_GNUCC OR "${CMAKE_C_COMPILER_ID}" MATCHES "Clang")
if(FFMPEG_INCLUDE_DIR_OLD_STYLE)
set(CMAKE_REQUIRED_INCLUDES ${CMAKE_REQUIRED_INCLUDES} ${FFMPEG_INCLUDE_DIR_OLD_STYLE})