7cfdf0a7d2
- Update to 145.1.2010.11.5 - Add PORTEPOCH - Change license GPLv2 to GPLv1 - Remove USE_ZIP=yes - USES gmake instead of USE_GMAKE - Add USE_GCC=yes - Use pkg-plist instead of PLIST_FILES and PORTDATA - Add DOCS Option - Support STAGEDIR - Change Desktop entry file - Symlink the icon instead of copying it - Break lines around 80 characters - Recreate patches with make makepatch
17 lines
699 B
Text
17 lines
699 B
Text
--- ./Makefile.orig 2010-11-04 08:53:00.000000000 +0100
|
|
+++ ./Makefile 2013-12-25 10:25:00.000000000 +0100
|
|
@@ -1,12 +1,9 @@
|
|
-CC = gcc
|
|
###CFLAGS = -Wall -O2 -I/usr/local/include/SDL -I/usr/include/SDL -D_REENTRANT
|
|
-CFLAGS = -O2 `sdl-config --cflags`
|
|
+CFLAGS += `sdl-config --cflags`
|
|
|
|
sdlscav: scav.o gfx.o sound.o edit.o anim.o
|
|
### gcc -o sdlscav scav.o gfx.o sound.o edit.o anim.o -lSDL -ldl -lpthread
|
|
- gcc -o sdlscav scav.o gfx.o sound.o edit.o anim.o `sdl-config --libs`
|
|
- install -m 0755 -d $$HOME/.scavenger
|
|
- install -m 0644 data/*rc $$HOME/.scavenger
|
|
+ ${CC} -o sdlscav scav.o gfx.o sound.o edit.o anim.o `sdl-config --libs`
|
|
|
|
scav.o: scav.c scav.h names.h edit.h anim.h gfx.h sound.h
|
|
|