230bad2776
- Upgrade to version 2.13.2 - Update MASTER_SITES to only include new gmsh site - Remove no-longer-needed definitions of DISTFILES, EXTRACT_ONLY, and WRKSRC - The licensing situation is simpler now: Gmsh itself is released under GPLv3+ [1], TetGen under AGPLv3+ [2], and METIS under an APACHE2 license [3] For now, TAUCS is the only component released under a non-standard license [4] - Fix misnamed KNOB in KNOB_DESC=, so `make config` shows descriptions - Fix errors/warnings reported by portlint and poudriere testport - Add missing entries to LIB_DEPENDS= - Add blaslapack to USES= - Change USE_GL=yes to USE_GL=gl glu - Add USE_XORG=x11 xext xfixes xft - Redo patches with make makepatch - Remove MAKE_JOBS_UNSAFE=yes - Remove options for bundled software - Update default options - Add patch to fix TAUCS linking error - Modernize option handling - Mark broken on FreeBSD 12 i386 due to clang bug: (https://llvm.org/bugs/show_bug.cgi?id=21903) - Remove unnecessary TAUCS_LIB_DEPENDS=libtaucs.so:math/taucs to prevent problems with french/aster - cad/gmsh includes a bundled taucs, so TAUCS_LIB_DEPENDS=libtaucs.so:math/taucs can be removed - math/taucs pulls in math/metis4, but french/aster, which depends on cad/gmsh, pulls in conflicting math/taucs-edf - Update pkg-plist [1] http://gmsh.info/#Licensing [2] http://wias-berlin.de/software/tetgen/1.5/FAQ-license.html [3] http://glaros.dtc.umn.edu/gkhome/metis/metis/faq?q=metis/metis/faq#cite [4] http://www.tau.ac.il/~stoledo/taucs/ PR: 212398 Reviewed by: swills (mentor) AMDmi3 (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D7703
11 lines
329 B
C++
11 lines
329 B
C++
--- Fltk/Main.cpp.orig 2016-08-28 23:27:04 UTC
|
|
+++ Fltk/Main.cpp
|
|
@@ -3,7 +3,7 @@
|
|
// See the LICENSE.txt file for license information. Please report all
|
|
// bugs and problems to the public mailing list <gmsh@onelab.info>.
|
|
|
|
-#include <stdlib.h>
|
|
+#include <cstdlib>
|
|
#include <string>
|
|
#include "Gmsh.h"
|
|
#include "GmshMessage.h"
|