freebsd-ports/net/quagga/files/extra-tcpmd5-patch-configure.ac
Bruce M Simpson 8ffa74d90d Add TCP-MD5 application level support to the FreeBSD quagga port.
Note that this still requires the network administrator to set up TCP-MD5
SAs in the system SADB via setkey(8).
2004-05-20 11:51:44 +00:00

16 lines
473 B
Text

--- configure.ac.orig Thu May 20 12:31:22 2004
+++ configure.ac Thu May 20 12:33:06 2004
@@ -163,6 +163,13 @@
AC_MSG_RESULT(no)
fi
+AC_ARG_ENABLE(tcp-signature,
+[ --enable-tcp-signature enable TCP MD5 checksum capability])
+
+if test "${enable_tcp_signature}" = "yes"; then
+ AC_DEFINE(TCP_MD5SIG,,TCP signatures)
+fi
+
if test "${enable_user}" = "yes" || test x"${enable_user}" = x""; then
enable_user="quagga"
elif test "${enable_user}" = "no"; then