af9671f003
Obtained from: https://bugzilla.mozilla.org/show_bug.cgi?id=315346 Approved by: portmgr (marcus)
218 lines
8.2 KiB
Text
218 lines
8.2 KiB
Text
Index: dom/public/idl/sidebar/Makefile.in
|
|
===================================================================
|
|
RCS file: dom/public/idl/sidebar/Makefile.in
|
|
diff -N dom/public/idl/sidebar/Makefile.in
|
|
--- /dev/null 1 Jan 1970 00:00:00 -0000
|
|
+++ dom/public/idl/sidebar/Makefile.in 4 Nov 2005 02:35:53 -0000
|
|
@@ -0,0 +1,53 @@
|
|
+#
|
|
+# ***** BEGIN LICENSE BLOCK *****
|
|
+# Version: MPL 1.1/GPL 2.0/LGPL 2.1
|
|
+#
|
|
+# The contents of this file are subject to the Mozilla Public License Version
|
|
+# 1.1 (the "License"); you may not use this file except in compliance with
|
|
+# the License. You may obtain a copy of the License at
|
|
+# http://www.mozilla.org/MPL/
|
|
+#
|
|
+# Software distributed under the License is distributed on an "AS IS" basis,
|
|
+# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
|
|
+# for the specific language governing rights and limitations under the
|
|
+# License.
|
|
+#
|
|
+# The Original Code is Sidebar IDL Makefile code.
|
|
+#
|
|
+# The Initial Developer of the Original Code is
|
|
+# Robert O'Callahan (rocallahan@novell.com)
|
|
+# Portions created by the Initial Developer are Copyright (C) 2005
|
|
+# the Initial Developer. All Rights Reserved.
|
|
+#
|
|
+# Contributor(s):
|
|
+#
|
|
+# Alternatively, the contents of this file may be used under the terms of
|
|
+# either of the GNU General Public License Version 2 or later (the "GPL"),
|
|
+# or the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
|
|
+# in which case the provisions of the GPL or the LGPL are applicable instead
|
|
+# of those above. If you wish to allow use of your version of this file only
|
|
+# under the terms of either the GPL or the LGPL, and not to allow others to
|
|
+# use your version of this file under the terms of the MPL, indicate your
|
|
+# decision by deleting the provisions above and replace them with the notice
|
|
+# and other provisions required by the GPL or the LGPL. If you do not delete
|
|
+# the provisions above, a recipient may use your version of this file under
|
|
+# the terms of any one of the MPL, the GPL or the LGPL.
|
|
+#
|
|
+# ***** END LICENSE BLOCK *****
|
|
+
|
|
+DEPTH = ../../../..
|
|
+topsrcdir = @top_srcdir@
|
|
+srcdir = @srcdir@
|
|
+VPATH = @srcdir@
|
|
+
|
|
+include $(DEPTH)/config/autoconf.mk
|
|
+
|
|
+MODULE = dom
|
|
+XPIDL_MODULE = dom_sidebar
|
|
+GRE_MODULE = 1
|
|
+
|
|
+XPIDLSRCS = \
|
|
+ nsISidebar.idl \
|
|
+ $(NULL)
|
|
+
|
|
+include $(topsrcdir)/config/rules.mk
|
|
Index: dom/public/idl/sidebar/nsISidebar.idl
|
|
===================================================================
|
|
RCS file: dom/public/idl/sidebar/nsISidebar.idl
|
|
diff -N dom/public/idl/sidebar/nsISidebar.idl
|
|
--- /dev/null 1 Jan 1970 00:00:00 -0000
|
|
+++ dom/public/idl/sidebar/nsISidebar.idl 10 Feb 2005 15:58:02 -0000
|
|
@@ -0,0 +1,70 @@
|
|
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*-
|
|
+ *
|
|
+ * ***** BEGIN LICENSE BLOCK *****
|
|
+ * Version: MPL 1.1/GPL 2.0/LGPL 2.1
|
|
+ *
|
|
+ * The contents of this file are subject to the Mozilla Public License Version
|
|
+ * 1.1 (the "License"); you may not use this file except in compliance with
|
|
+ * the License. You may obtain a copy of the License at
|
|
+ * http://www.mozilla.org/MPL/
|
|
+ *
|
|
+ * Software distributed under the License is distributed on an "AS IS" basis,
|
|
+ * WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
|
|
+ * for the specific language governing rights and limitations under the
|
|
+ * License.
|
|
+ *
|
|
+ * The Original Code is mozilla.org Code.
|
|
+ *
|
|
+ * The Initial Developer of the Original Code is
|
|
+ * Netscape Communications Corporation.
|
|
+ * Portions created by the Initial Developer are Copyright (C) 1998
|
|
+ * the Initial Developer. All Rights Reserved.
|
|
+ *
|
|
+ * Contributor(s):
|
|
+ *
|
|
+ * Alternatively, the contents of this file may be used under the terms of
|
|
+ * either the GNU General Public License Version 2 or later (the "GPL"), or
|
|
+ * the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
|
|
+ * in which case the provisions of the GPL or the LGPL are applicable instead
|
|
+ * of those above. If you wish to allow use of your version of this file only
|
|
+ * under the terms of either the GPL or the LGPL, and not to allow others to
|
|
+ * use your version of this file under the terms of the MPL, indicate your
|
|
+ * decision by deleting the provisions above and replace them with the notice
|
|
+ * and other provisions required by the GPL or the LGPL. If you do not delete
|
|
+ * the provisions above, a recipient may use your version of this file under
|
|
+ * the terms of any one of the MPL, the GPL or the LGPL.
|
|
+ *
|
|
+ * ***** END LICENSE BLOCK ***** */
|
|
+
|
|
+/*
|
|
+
|
|
+ The Sidebar API for 3rd parties
|
|
+
|
|
+*/
|
|
+
|
|
+#include "nsISupports.idl"
|
|
+
|
|
+[scriptable, uuid(577CB745-8CAF-11d3-AAEF-00805F8A4905)]
|
|
+interface nsISidebar : nsISupports
|
|
+{
|
|
+ void addPanel(in wstring aTitle, in string aContentURL,
|
|
+ in string aCustomizeURL);
|
|
+ void addPersistentPanel(in wstring aTitle, in string aContentURL,
|
|
+ in string aCustomizeURL);
|
|
+ void addSearchEngine(in string engineURL, in string iconURL,
|
|
+ in wstring suggestedTitle, in wstring suggestedCategory);
|
|
+};
|
|
+
|
|
+%{ C++
|
|
+// {577CB744-8CAF-11d3-AAEF-00805F8A4905}
|
|
+#define NS_SIDEBAR_CID \
|
|
+{ 0x577cb744, 0x8caf, 0x11d3, { 0xaa, 0xef, 0x0, 0x80, 0x5f, 0x8a, 0x49, 0x5 } }
|
|
+
|
|
+#define NS_SIDEBAR_CONTRACTID "@mozilla.org/sidebar;1"
|
|
+%}
|
|
+
|
|
+/*
|
|
+ var isidebar = Components.interfaces.nsISidebar;
|
|
+ var csidebar = Components.classes['@mozilla.org/sidebar;1'];
|
|
+ var sidebar = csidebar.createInstance(isidebar);
|
|
+*/
|
|
Index: xpinstall/packager/packages-static-unix
|
|
===================================================================
|
|
RCS file: /home/rocallahan/mozilla-cvs-mirror/mozilla/xpinstall/packager/packages-static-unix,v
|
|
retrieving revision 1.87
|
|
diff -u -t -p -1 -2 -r1.87 packages-static-unix
|
|
--- xpinstall/packager/packages-static-unix 19 Aug 2005 23:09:31 -0000 1.87
|
|
+++ xpinstall/packager/packages-static-unix 4 Nov 2005 02:39:13 -0000
|
|
@@ -89,24 +89,25 @@ bin/components/caps.xpt
|
|
bin/components/cookie.xpt
|
|
bin/components/jsdservice.xpt
|
|
bin/components/libjsd.so
|
|
bin/components/dom.xpt
|
|
bin/components/dom_base.xpt
|
|
bin/components/dom_canvas.xpt
|
|
bin/components/dom_core.xpt
|
|
bin/components/dom_css.xpt
|
|
bin/components/dom_events.xpt
|
|
bin/components/dom_loadsave.xpt
|
|
bin/components/dom_html.xpt
|
|
bin/components/dom_range.xpt
|
|
+bin/components/dom_sidebar.xpt
|
|
bin/components/dom_stylesheets.xpt
|
|
bin/components/dom_traversal.xpt
|
|
bin/components/dom_views.xpt
|
|
bin/components/dom_xbl.xpt
|
|
bin/components/dom_xpath.xpt
|
|
bin/components/dom_xul.xpt
|
|
bin/components/editor.xpt
|
|
bin/components/find.xpt
|
|
bin/components/gfx.xpt
|
|
bin/components/gfx2.xpt
|
|
bin/components/gksvgrenderer.xpt
|
|
bin/components/intl.xpt
|
|
Index: xpinstall/packager/packages-unix
|
|
===================================================================
|
|
RCS file: /home/rocallahan/mozilla-cvs-mirror/mozilla/xpinstall/packager/packages-unix,v
|
|
retrieving revision 1.314
|
|
diff -u -t -p -1 -2 -r1.314 packages-unix
|
|
--- xpinstall/packager/packages-unix 31 Oct 2005 13:21:31 -0000 1.314
|
|
+++ xpinstall/packager/packages-unix 4 Nov 2005 02:38:56 -0000
|
|
@@ -106,24 +106,25 @@ bin/components/nsComposerCmdLineHandler.
|
|
bin/components/cookie.xpt
|
|
bin/components/libjsd.so
|
|
bin/components/jsdservice.xpt
|
|
bin/components/dom.xpt
|
|
bin/components/dom_base.xpt
|
|
bin/components/dom_canvas.xpt
|
|
bin/components/dom_core.xpt
|
|
bin/components/dom_css.xpt
|
|
bin/components/dom_events.xpt
|
|
bin/components/dom_html.xpt
|
|
bin/components/dom_loadsave.xpt
|
|
bin/components/dom_range.xpt
|
|
+bin/components/dom_sidebar.xpt
|
|
bin/components/dom_stylesheets.xpt
|
|
bin/components/dom_traversal.xpt
|
|
bin/components/dom_views.xpt
|
|
bin/components/dom_xbl.xpt
|
|
bin/components/dom_xpath.xpt
|
|
bin/components/dom_xul.xpt
|
|
bin/components/editor.xpt
|
|
bin/components/find.xpt
|
|
bin/components/gfx.xpt
|
|
bin/components/gksvgrenderer.xpt
|
|
bin/components/intl.xpt
|
|
bin/components/imglib2.xpt
|
|
Index: dom/public/idl/Makefile.in
|
|
===================================================================
|
|
RCS file: /cvsroot/mozilla/dom/public/idl/Makefile.in,v
|
|
retrieving revision 1.13
|
|
diff -u -p -r1.13 Makefile.in
|
|
--- dom/public/idl/Makefile.in 18 Apr 2005 06:33:17 -0000 1.13
|
|
+++ dom/public/idl/Makefile.in 7 Nov 2005 08:39:01 -0000
|
|
@@ -51,6 +51,7 @@ DIRS = \
|
|
stylesheets \
|
|
views \
|
|
css \
|
|
+ sidebar \
|
|
traversal \
|
|
range \
|
|
xbl \
|