freebsd-ports/www/tidy-devel/files/patch-build_gmake_Makefile
2008-06-22 09:15:43 +00:00

33 lines
963 B
Text

--- build/gmake/Makefile.orig 2008-03-22 22:13:38.000000000 +0100
+++ build/gmake/Makefile 2008-06-21 15:52:41.000000000 +0200
@@ -58,8 +58,8 @@
PROJECT=tidy
# Installation variables. Spaces OK, only dir create and file copy operations.
-runinst_prefix=/usr/local
-devinst_prefix=/usr/local
+runinst_prefix=${PREFIX}
+devinst_prefix=${PREFIX}
bininst = ${runinst_prefix}/bin
libinst = ${devinst_prefix}/lib
@@ -67,7 +67,7 @@
maninst = ${devinst_prefix}/man
# Internal variables. - No spaces allowed: libtool chokes on spaces in directory names.
-TOPDIR = ../..
+TOPDIR = .
INCDIR = ${TOPDIR}/include
APPDIR = ${TOPDIR}/console
SRCDIR = ${TOPDIR}/src
@@ -90,8 +90,8 @@
# CFLAGS etc..
# For optimised builds, flags such as "-O2" should be added and -D_DEBUG=1
# disabled.
-CC= gcc
-CFLAGS= -g -pedantic -Wall -I $(INCDIR)
+#CC= gcc
+CFLAGS+= -pedantic -Wall -I $(INCDIR) -fPIC
# flags only supported with gcc 3.x
CFLAGS += -Wunused-parameter