freebsd-ports/devel/cocktail/files/patch-r2l-src-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

37 lines
1,004 B
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./r2l/src/Makefile Tue Feb 15 14:26:26 1994
+++ ./r2l/src/Makefile Thu Aug 5 18:49:31 2004
@@ -15,14 +15,14 @@
echo p r2l | mc -d ../../reuse/src
Scanner.mi Scanner.md: r2l.rex
- rex -d r2l.rex;
+ $(REX) -d r2l.rex;
Parser.mi Parser.md: r2l.lalr
- lalr -b -d r2l.lalr;
+ $(LALR) -b -d r2l.lalr;
install: r2l r2l.sh $(LIB)/r2l
if test $(LIB) = $(BIN); then echo error: BIN = LIB; false; else true; fi
- sed "s;LIB;$(LIB);g" < r2l.sh > $(BIN)/r2l
+ $(SED) "s;LIB;$(LIB);g" < r2l.sh > $(BIN)/r2l
chmod a+rx $(BIN)/r2l
install -c -s -m 755 r2l $(LIB)/r2l
@@ -35,12 +35,13 @@
# co RCS/*
make $(SOURCES)
ln *.m[id] ../m2c
- rm -f ../m2c/*.[hc]
+ -rm -f ../m2c/*.[hc]
cd ../m2c; make sources M2FLAGS="-c -d../../reuse/src"
cd ../m2c; rm -f *.m[id]
clean:
- rm -f core *.[dimor] ERRORS LISTING _Debug r2l
+ -rm -f $(STDCLEAN)
+ -rm -f *.[dimor] ERRORS LISTING _Debug r2l
CLEAN: clean
- rm -f $(SOURCES)
+ -rm -f $(SOURCES)