freebsd-ports/devel/cocktail/files/patch-rex-test-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

57 lines
1.3 KiB
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./rex/test/Makefile Tue Feb 15 14:28:08 1994
+++ ./rex/test/Makefile Thu Aug 5 18:49:07 2004
@@ -1,7 +1,3 @@
-LIB = $(HOME)/lib
-MLIB = ../../reuse/src
-CFLAGS = -I../../reuse/c
-CC = cc
# target language C
@@ -16,7 +12,7 @@
Source.o: Source.h
ScannerDrv.c Scanner.h Scanner.c Source.h Source.c: modula.c
- rex -sdc1 modula.c;
+ $(REX) -sdc1 modula.c;
# target language Modula using MOCKA (mc)
@@ -25,7 +21,7 @@
make test
ScannerDrv.mi Scanner.md Scanner.mi Source.md Source.mi: modula.m
- rex -sdm1 modula.m;
+ $(REX) -sdm1 modula.m;
# target language Modula using SUN modula compiler (m2c)
@@ -34,7 +30,7 @@
make test
ScannerDrv.mod Scanner.def Scanner.mod Source.def Source.mod: modula.m
- rex -sdm1 modula.m;
+ $(REX) -sdm1 modula.m;
# target language Eiffel
@@ -43,7 +39,7 @@
make test
scanner.e scannerdrv.e source.e attribute.e lsarray.e statecontrol.e: modula.e
- rex -sde1 modula.e;
+ $(REX) -sde1 modula.e;
test:
time ScannerDrv < in
@@ -56,7 +52,7 @@
lint $(CFLAGS) -u ScannerDrv.c Scanner.c Source.c
clean:
- rm -f Scan* Source* scan* [alst]*.e core
+ -rm -f $(STDCLEAN)
+ -rm -f Scan* Source* scan* [alst]*.e
-.c.o:
- $(CC) $(CFLAGS) -c $*.c;
+.include "../../Makefile.inc"