freebsd-ports/devel/cocktail/files/patch-specs-modula-oberon-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

24 lines
813 B
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./specs/modula/oberon/Makefile Tue Feb 15 14:29:03 1994
+++ ./specs/modula/oberon/Makefile Wed Aug 25 11:42:24 2004
@@ -8,14 +8,16 @@
lpp -xzj oberon.pars;
oberon.rex: oberon.scan Scanner.rpp
- rpp < oberon.scan > oberon.rex;
+ $(RPP) < oberon.scan > oberon.rex;
Scanner.md Scanner.mi: oberon.rex
- rex -d oberon.rex;
+ $(REX) -d oberon.rex;
Parser.md Parser.mi ParserDrv.mi: Parser.lalr
- lalr -d -p Parser.lalr;
+ $(LALR) -d -p Parser.lalr;
clean:
- rm -f Scanner.m? Parser.m? ParserDrv.mi ParserDrv
- rm -f core *.[dimor] _Debug oberon.rex Parser.lalr Scanner.rpp *.bak
+ -rm -f Scanner.m? Parser.m? ParserDrv.mi ParserDrv
+ -rm -f $(STDCLEAN)
+ -rm -f *.[dimor] _Debug oberon.rex Parser.lalr Scanner.rpp *.bak
+.include "../../Makefile.inc"