0a56d0ccd8
debugger and the browser's JavaScript. There's no compiling of code to JavaScript to view it in the browser. You can use the same edit-refresh-view cycle you're used to with JavaScript, while at the same time inspect variables, set breakpoints, and utilize all the other debugger tools available to you with Java. And because GWT's development mode is now in the browser itself, you can use tools like Firebug and Inspector as you code in Java. PR: ports/143042 Submitted by: Jonathan Chen <jonc at chen.org.nz>
78 lines
2.6 KiB
Text
78 lines
2.6 KiB
Text
--- /tmp/gwt-plugins-release-2.0/xpcom/Makefile 2010-01-19 08:52:13.000000000 +1300
|
|
+++ ./xpcom/Makefile 2010-01-18 08:52:57.000000000 +1300
|
|
@@ -20,6 +20,14 @@
|
|
# GECKO_PLATFORM XPCOM ABI (ie, Linux_x86_64-gcc3)
|
|
#
|
|
|
|
+ifeq ($(OS),freebsd)
|
|
+DEFAULT_FIREFOX_LIBS ?= /usr/local/lib/firefox3
|
|
+RUN_PATH_FLAG = -rpath-link
|
|
+DLL_SUFFIX = .so
|
|
+DLLFLAGS = -shared -m${FLAG32BIT}
|
|
+TARGET_PLATFORM = FreeBSD_x86_64-gcc3
|
|
+endif
|
|
+
|
|
ifeq ($(OS),mac)
|
|
DEFAULT_FIREFOX_LIBS ?= /Applications/Firefox.app/Contents/MacOS
|
|
RUN_PATH_FLAG = -executable_path
|
|
@@ -47,8 +55,8 @@
|
|
export FLAG32BIT
|
|
|
|
ifeq ($(BROWSER),)
|
|
-$(warning Defaulting to FF3 build [set with BROWSER=ff2, ff3, ff3+, or ff35])
|
|
-BROWSER=ff3
|
|
+$(warning Defaulting to FF35 build [set with BROWSER=ff2, ff3, ff3+, or ff35])
|
|
+BROWSER=ff35
|
|
endif
|
|
|
|
GECKO_MINOR_VERSION=
|
|
@@ -79,8 +87,6 @@
|
|
CXXFLAGS = $(CXXONLYFLAGS) $(CFLAGS)
|
|
DIR = $(shell pwd)
|
|
|
|
-# Set $PLUGIN_SDKS if it isn't in the default location
|
|
-PLUGIN_SDKS ?= ../../../plugin-sdks
|
|
GECKO_PLATFORM ?= $(TARGET_PLATFORM)
|
|
|
|
COMMON = ../common/libcommon$(FLAG32BIT).a
|
|
@@ -97,12 +103,10 @@
|
|
FF_HEADER = prebuilt/$(BROWSER)/include/IOOPHM.h
|
|
INSTALL_RDF = $(EXTENSION_OUTDIR)/install.rdf
|
|
|
|
-SDK_PATH = $(PLUGIN_SDKS)/gecko-sdks
|
|
-GECKO_SDK = $(SDK_PATH)/gecko-$(BROWSER_VERSION)
|
|
-GECKO_PLAT_INC = $(GECKO_SDK)/$(GECKO_PLATFORM)/include
|
|
-GECKO_LIBS = $(GECKO_SDK)/$(GECKO_PLATFORM)/lib$(GECKO_MINOR_VERSION)
|
|
-XPIDL = $(GECKO_SDK)/$(GECKO_PLATFORM)/bin/xpidl
|
|
-XPIDL_FLAGS = -I$(GECKO_SDK)/idl
|
|
+GECKO_PLAT_INC = ${LOCALBASE}/include/firefox3/unstable
|
|
+GECKO_LIBS = ${LOCALBASE}/lib/firefox3/sdk/lib
|
|
+XPIDL = ${LOCALBASE}/lib/libxul/xpidl
|
|
+XPIDL_FLAGS = -I${LOCALBASE}/share/idl/firefox3/unstable
|
|
|
|
#DLLFLAGS += \
|
|
# -L$(GECKO_LIBS) \
|
|
@@ -112,12 +116,13 @@
|
|
# -Wl,$(RUN_PATH_FLAG),$(DEFAULT_FIREFOX_LIBS) \
|
|
# -lxpcomglue_s -lxpcom -lnspr4 -lmozjs
|
|
DLLFLAGS += \
|
|
+ -L${LOCALBASE}/lib \
|
|
-L$(DEFAULT_FIREFOX_LIBS) \
|
|
-L$(GECKO_LIBS) \
|
|
-Wl,$(RUN_PATH_FLAG),$(GECKO_LIBS) \
|
|
-lxpcomglue_s -lxpcom -lnspr4 -lmozjs
|
|
|
|
-INC += -I$(GECKO_PLAT_INC) -I$(GECKO_SDK)/include -I$(dir $(FF_HEADER))
|
|
+INC += -I$(dir $(FF_HEADER)) -I$(GECKO_PLAT_INC) -I${LOCALBASE}/include/nspr
|
|
|
|
VERSION=0.9.$(shell ./getversion).$(shell date +%Y%m%d%H%M%S)
|
|
|
|
@@ -212,7 +217,7 @@
|
|
endif
|
|
|
|
DEPEND = g++ -MM -MT'$$(OBJ_OUTDIR)/$(patsubst %.cpp,%.o,$(src))' \
|
|
- -I. -I../common -isystem$(dir $(FF_HEADER)) -isystem$(GECKO_SDK)/include $(src) &&
|
|
+ -I. -I../common -isystem$(dir $(FF_HEADER)) $(src) &&
|
|
depend: browser $(OBJ_OUTDIR) $(FF_HEADER)
|
|
($(foreach src,$(SRCS),$(DEPEND)) true) >>Makefile
|
|
# makedepend -- $(CFLAGS) -- $(SRCS)
|