freebsd-ports/multimedia/gstreamer-plugins/files/patch-ext_libcaca_Makefile.in
Michael Johnson daf4cc81e4 - split multimedia/gstreamer-plugins in to individual ports per
gstreamer plugin (52 new ports).
- Chase changes to ports that used USE_GNOME=gstreamerplugisn
   to use new USE_GSTREAMER= macro, Bump PORTREVISION's

--

Examples of new USE_GSTREAMER macro:

 USE_GSTREAMER=        dvd lame flac
 .include <bsd.port.mk>

 If you want to use USE_GSTREAMER after <bsd.port.pre.mk>
 you must follow one of the examples listed below

       WANT_GSTREAMER= yes
       .include <bsd.port.pre.mk>
       .if defined(WITH_VORBIS)
       USE_GSTREAMER+= vorbis
       .endif

 or
       USE_GSTREAMER=  yes
       .include <bsd.port.pre.mk>
       .if defined(WITH_FAAD)
       USE_GSTREAMER+= faad
       .endif

Note: USE_GSTREAMER=yes will always add a dependency to
               ports/multimedia/gstreamer-plugins

--

Thanks to krion for runing this on pointyhat

Thanks to kwm for helping with this, and many bug fixes , and updates.
2005-02-28 22:16:10 +00:00

23 lines
1 KiB
Text

--- ext/libcaca/Makefile.in.orig Mon Oct 4 00:07:18 2004
+++ ext/libcaca/Makefile.in Mon Oct 4 00:07:59 2004
@@ -76,8 +76,7 @@
pluginLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(plugin_LTLIBRARIES)
am__DEPENDENCIES_1 =
-libgstcacasink_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
- $(top_builddir)/gst-libs/gst/libgstinterfaces-$(GST_MAJORMINOR).la
+libgstcacasink_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
am_libgstcacasink_la_OBJECTS = libgstcacasink_la-gstcacasink.lo
libgstcacasink_la_OBJECTS = $(am_libgstcacasink_la_OBJECTS)
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
@@ -616,9 +615,7 @@
plugin_LTLIBRARIES = libgstcacasink.la
libgstcacasink_la_SOURCES = gstcacasink.c
libgstcacasink_la_CFLAGS = $(GST_CFLAGS) $(LIBCACA_CFLAGS)
-libgstcacasink_la_LIBADD = $(LIBCACA_LIBS) \
- $(top_builddir)/gst-libs/gst/libgstinterfaces-$(GST_MAJORMINOR).la
-
+libgstcacasink_la_LIBADD = $(LIBCACA_LIBS) -lgstinterfaces-%%VERSION%%
libgstcacasink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstcacasink.h
all: all-am