freebsd-ports/games/quake2lnx/files/patch-src_qcommon_files.c
Alejandro Pulver 92050f2818 - Bump PORTREVISION.
- Remove ROGUE and XATRIX options (moved to "games/quake2-rogue" and
  "games/quake2-xatrix").
- Rename "sdlquake2" to "quake2-sdl" to avoid conflicting with
  "games/sdlquake2".
- Depend on "games/quake2-extras" for the RETEXTURE option instead of
  installing them directly (most Q2 engines in ports support them).
- Install maxpak.pak in ${LIBDIR} (private directory) and not in ${Q2DIR}
  (global directory). Other engines have their own pak/pk3 files.
- Fix reversed mouse when doing very slow movements (like when aiming at a long
  distance). It's the same fix as sent to "games/warsow".
- Follow the rules in "games/quake2-data/Makefile.include": fix handling of
  search paths (DATADIR/LIBDIR weren't used when playing a modification, also
  use the right order).

PR:		ports/101010
Submitted by:	alepulver
Approved by:	maintainer (timeout)
2006-08-14 20:38:43 +00:00

20 lines
718 B
C

--- src/qcommon/files.c.orig Sun Jan 2 00:38:12 2005
+++ src/qcommon/files.c Thu Jul 27 17:07:25 2006
@@ -680,6 +680,8 @@
Cvar_FullSet ("gamedir", dir, CVAR_SERVERINFO|CVAR_NOSET);
if (fs_cddir->string[0])
FS_AddGameDirectory (va("%s/%s", fs_cddir->string, dir) );
+ FS_AddGameDirectory (va("%%DATADIR%%/%s", dir));
+ FS_AddGameDirectory (va("%%LIBDIR%%/%s", dir));
FS_AddGameDirectory (va("%s/%s", fs_basedir->string, dir) );
FS_AddHomeAsGameDirectory(dir);
}
@@ -912,6 +914,8 @@
//
// add baseq2 to search path
//
+ FS_AddGameDirectory ("%%DATADIR%%/"BASEDIRNAME);
+ FS_AddGameDirectory ("%%LIBDIR%%/"BASEDIRNAME);
FS_AddGameDirectory (va("%s/"BASEDIRNAME, fs_basedir->string) );
//