8937ed4066
The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
109 lines
2.4 KiB
Text
109 lines
2.4 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./mtc/m2c/Makefile Tue Feb 15 14:24:29 1994
|
|
+++ ./mtc/m2c/Makefile Thu Aug 5 18:49:18 2004
|
|
@@ -1,43 +1,37 @@
|
|
-BIN = $(HOME)/bin
|
|
-LIB = $(HOME)/lib
|
|
-OPT = -O
|
|
-CC = cc
|
|
|
|
- # C library (reuse)
|
|
-REUSE = ../../reuse/m2c
|
|
+.include "../../Makefile.inc"
|
|
|
|
- # C library
|
|
-CLIBS = $(REUSE)/libreuse.a
|
|
+ROOTDIR = ../..
|
|
+CFLAGS += -I$(INCDIR)
|
|
+CLIBS += $(REUSELIB)
|
|
|
|
- # options for cc
|
|
-CFLAGS = -w -I$(REUSE) $(OPT)
|
|
+RTS = $(INCDIR)/SYSTEM_.h $(INCDIR)/SYSTEM_.c Arguments.h Arguments.c
|
|
|
|
- # options for mtc
|
|
-M2FLAGS = -c
|
|
+all: mtc
|
|
|
|
- # "runtime system"
|
|
-RTS = SYSTEM_.h SYSTEM_.c Arguments.h Arguments.c
|
|
-
|
|
-all :
|
|
-
|
|
-install: mtc $(BIN) $(LIB)/mtc
|
|
- if test $(LIB) = $(BIN); then echo error: BIN = LIB; false; else true; fi
|
|
- install -c -s -m 755 mtc $(BIN)
|
|
- cp $(RTS) $(LIB)/mtc
|
|
- chmod a+r $(LIB)/mtc/*.[hc]
|
|
+install: mtc $(DESTBIN) $(DESTLIB)/mtc
|
|
+ if test $(DESTLIB) = $(DESTBIN); then echo error: DESTBIN = DESTLIB; false; else true; fi
|
|
+ install -c -s -m 755 mtc $(DESTBIN)
|
|
+ cp $(RTS) $(DESTLIB)/mtc
|
|
+ chmod a+r $(DESTLIB)/mtc/*.[hc]
|
|
|
|
# installation directories
|
|
|
|
-$(BIN):
|
|
- sh -c "if test ! -d $(BIN); then mkdir -p $(BIN); else true; fi"
|
|
+$(DESTBIN):
|
|
+ sh -c "if test ! -d $(DESTBIN); then mkdir -p $(DESTBIN); else true; fi"
|
|
|
|
-$(LIB):
|
|
- sh -c "if test ! -d $(LIB); then mkdir -p $(LIB); else true; fi"
|
|
+$(DESTLIB):
|
|
+ sh -c "if test ! -d $(DESTLIB); then mkdir -p $(DESTLIB); else true; fi"
|
|
|
|
-$(LIB)/mtc: $(LIB)
|
|
- sh -c "if test ! -d $(LIB)/mtc; then mkdir -p $(LIB)/mtc; else true; fi"
|
|
+$(DESTLIB)/mtc: $(DESTLIB)
|
|
+ sh -c "if test ! -d $(DESTLIB)/mtc; then mkdir -p $(DESTLIB)/mtc; else true; fi"
|
|
|
|
|
|
+clean:
|
|
+ -rm -f $(STDCLEAN)
|
|
+ -rm -f *.o
|
|
+ -rm -f mtc
|
|
+
|
|
# HEAD
|
|
|
|
sources : AssocTab.h
|
|
@@ -236,9 +230,10 @@
|
|
mtc.o : Defs.h
|
|
mtc.o : Code.h
|
|
|
|
-SYSTEM_.o : SYSTEM_.c SYSTEM_.h
|
|
+# SYSTEM_.o : SYSTEM_.c SYSTEM_.h
|
|
|
|
-mtc : $(SYSTEM) \
|
|
+# mtc : $(SYSTEM) \
|
|
+mtc : \
|
|
mtc.o \
|
|
Code.o \
|
|
Values.o \
|
|
@@ -257,7 +252,7 @@
|
|
Semantics.o \
|
|
DefMods.o \
|
|
Parser.o \
|
|
-; $(CC) $(CFLAGS) -o mtc $(SYSTEM) \
|
|
+; $(CC) $(CFLAGS) -o mtc \
|
|
mtc.o \
|
|
Code.o \
|
|
Values.o \
|
|
@@ -278,18 +273,3 @@
|
|
Parser.o \
|
|
$(CLIBS)
|
|
|
|
-# TAIL
|
|
-
|
|
-clean :
|
|
- rm -f core *.o
|
|
-
|
|
-.SUFFIXES: .md .mi .h .c .o
|
|
-
|
|
-.mi.c:
|
|
- mtc2 $(M2FLAGS) $*.mi;
|
|
-
|
|
-.md.h:
|
|
- mtc2 $(M2FLAGS) $*.md;
|
|
-
|
|
-.c.o:
|
|
- $(CC) $(CFLAGS) -c $*.c
|