8937ed4066
The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
44 lines
1.3 KiB
Text
44 lines
1.3 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./mtc/make/Makefile Tue Feb 15 14:24:53 1994
|
|
+++ ./mtc/make/Makefile Thu Aug 5 18:49:21 2004
|
|
@@ -26,10 +26,10 @@
|
|
sh -c "if test ! -d $(LIB)/makemake; then mkdir -p $(LIB)/makemake; else true; fi"
|
|
|
|
Scanner.md Scanner.mi: modula.rex
|
|
- rex -d modula.rex;
|
|
+ $(REX) -d modula.rex;
|
|
|
|
Parser.md Parser.mi: modula.ell
|
|
- ell -di modula.ell;
|
|
+ $(ELL) -di modula.ell;
|
|
|
|
m2c: $(SRCM) $(GEN)
|
|
make sources M2FLAGS="-c -d../../reuse/src" -f MakefileC
|
|
@@ -38,9 +38,9 @@
|
|
|
|
modId: modula.rex
|
|
echo SCANNER modId | cat - modula.rex | \
|
|
- sed 's/\(RETURN.*Ident\)/yyEcho; IO.WriteNl (IO.StdOutput); \1/' | \
|
|
- $(BIN).t/rex -sd;
|
|
- sed 's/@/modId/' < ../../front/src/Id.mi > modIdDrv.mi
|
|
+ $(SED) 's/\(RETURN.*Ident\)/yyEcho; IO.WriteNl (IO.StdOutput); \1/' | \
|
|
+ $(REX) -sd;
|
|
+ $(SED) 's/@/modId/' < ../../front/src/Id.mi > modIdDrv.mi
|
|
echo p modIdDrv | mc -d ../../reuse/src
|
|
mv modIdDrv modId
|
|
|
|
@@ -53,10 +53,12 @@
|
|
sh -c "if test ! -d $(LIB)/Id; then mkdir -p $(LIB)/Id; else true; fi"
|
|
|
|
cleanId:
|
|
- rm -f modId*
|
|
+ -rm -f modId*
|
|
|
|
clean: cleanId
|
|
- rm -f *.[dimor] core ERRORS LISTING *.bak
|
|
+ -rm -f $(STDCLEAN)
|
|
+ -rm -f *.[dimor] ERRORS LISTING *.bak
|
|
|
|
CLEAN: clean
|
|
- rm -f [A-Z]*.[hc] Parser.m? Scanner.m? GetImports
|
|
+ -rm -f [A-Z]*.[hc] Parser.m? Scanner.m? GetImports
|
|
+.include "../../Makefile.inc"
|