freebsd-ports/devel/cocktail/files/patch-specs-c-wag-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

118 lines
3.5 KiB
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./specs/c/wag/Makefile Tue Feb 15 14:28:50 1994
+++ ./specs/c/wag/Makefile Wed Aug 25 12:03:56 2004
@@ -1,7 +1,7 @@
-LIB = $(HOME)/lib
-INCDIR = $(LIB)/include
-CFLAGS = -I$(INCDIR)
-CC = cc
+ROOTDIR= ../../..
+.include "../../Makefile.inc"
+
+CFLAGS = $(TCFLAGS) -I $(TMPINC)
SOURCES = Scanner.h Scanner.c Parser.h Parser.c Tree.h Tree.c Semantics.h Semantics.c \
Types.h Types.c ICode.h ICode.c ICodeInter.h ICodeInter.c minilax.c
@@ -9,38 +9,38 @@
OBJS = minilax.o Scanner.o Parser.o Tree.o Types.o Semantics.o ICode.o ICodeInter.o
all: minilax
- time minilax < in1
- time minilax < in5
+ time ./minilax < in1
+ time ./minilax < in1
minilax: $(OBJS)
- $(CC) $(CFLAGS) -o minilax $(OBJS) $(LIB)/libreuse.a -lm
+ $(CC) $(CFLAGS) -o minilax $(OBJS) -L $(TMPLIB) -l reuse -lm
Scanner.rpp Parser.lalr: minilax.pars
- lpp -cxzj minilax.pars;
+ $(LPP) -cxzj minilax.pars;
minilax.rex: minilax.scan Scanner.rpp
- rpp < minilax.scan > minilax.rex;
+ $(RPP) < minilax.scan > minilax.rex;
Scanner.h Scanner.c: minilax.rex
- rex -cd minilax.rex;
+ $(REX) -cd minilax.rex;
Parser.h Parser.c: Parser.lalr
- lalr -c -d Parser.lalr;
+ $(LALR) -c -d Parser.lalr;
Tree.h Tree.c: minilax.cg
- cg -cdimRDIL minilax.cg;
+ $(CG) -cdimRDIL minilax.cg;
Semantics.h Semantics.c: minilax.cg
- cg -cDIL minilax.cg;
+ $(CG) -cDIL minilax.cg;
Tree.TS: minilax.cg
- echo SELECT AbstractSyntax Output | cat - minilax.cg | cg -c4
+ echo SELECT AbstractSyntax Output | cat - minilax.cg | $(CG) -c4
Types.h Types.c: Types.puma Tree.TS
- puma -cdipk Types.puma;
+ $(PUMA) -cdipk Types.puma;
ICode.h ICode.c: ICode.puma Tree.TS
- puma -cdi ICode.puma;
+ $(PUMA) -cdi ICode.puma;
Scanner.o: Scanner.h
Parser.o: Parser.h Tree.h Scanner.h
@@ -54,36 +54,34 @@
lint $(CFLAGS) -u *.c
test: $(SOURCES)
- cg -cdimRDI0 minilax.cg;
+ $(CG) -cdimRDI0 minilax.cg;
make minilax LIB=$(LIB)
- tcsh -c "time minilax < in5; time minilax < in5; time minilax < in5; time minilax < in5"
+ tcsh -c "time ./minilax < in1; time ./minilax < in1; time ./minilax < in1; time ./minilax < in1"
wc Semantics.c
size Semantics.o
- cg -cdimRDI09 minilax.cg;
+ $(CG) -cdimRDI09 minilax.cg;
make minilax LIB=$(LIB)
- time minilax < in5
- cg -cdimRDI minilax.cg;
+ time ./minilax < in1
+ $(CG) -cdimRDI minilax.cg;
make minilax LIB=$(LIB)
- tcsh -c "time minilax < in5; time minilax < in5; time minilax < in5; time minilax < in5"
+ tcsh -c "time ./minilax < in1; time ./minilax < in1; time ./minilax < in1; time ./minilax < in1"
wc Semantics.c
size Semantics.o
- cg -cdimRDI9 minilax.cg;
+ $(CG) -cdimRDI9 minilax.cg;
make minilax LIB=$(LIB)
- time minilax < in5
- cg -cdimRDIL minilax.cg;
+ time ./minilax < in1
+ $(CG) -cdimRDIL minilax.cg;
make minilax LIB=$(LIB)
- tcsh -c "time minilax < in5; time minilax < in5; time minilax < in5; time minilax < in5"
+ tcsh -c "time ./minilax < in1; time ./minilax < in1; time ./minilax < in1; time ./minilax < in1"
wc Semantics.c
size Semantics.o
- cg -cdimRDIL9 minilax.cg;
+ $(CG) -cdimRDIL9 minilax.cg;
make minilax LIB=$(LIB)
- time minilax < in5
+ time ./minilax < in1
clean:
- rm -f Scanner.? Parser.? Tree.? Semantics.? Types.? ICode.? *.TS yy*.w *.o
- rm -f core _Debug minilax *Tab minilax.rex Parser.lalr Scanner.rpp
-
-.SUFFIXES: .c .o
+ -rm -f Scanner.? Parser.? Tree.? Semantics.?
+ -rm -f Types.? ICode.? *.TS yy*.w *.o
+ -rm -f $(STDCLEAN)
+ -rm -f _Debug minilax *Tab minilax.rex Parser.lalr Scanner.rpp
-.c.o:
- $(CC) $(CFLAGS) -c $*.c