The current USES=nodejs has the following issues: - www/node is not the default version while www/node16 is. - It also means inconsistent naming of node ports. - www/npm duplicates with www/npm-node16. - www/yarn duplicates with www/yarn-node16. The notable changes are introduced to fix the above issues: - Rewrite Mk/Uses/nodejs.mk. - Add new LTS version of nodejs (www/noe18). - Add new current version of nodejs (www/node19). - Change default nodejs version from 16 to 18 (latest LTS). - Use consistent naming for all supported node versions. - Convert www/node, www/npm and www/yarn to meta ports. After this commit: - All supported node versions are named as node{14,16,18,19} - www/node is a meta port which depends on the default version (e.g. www/node18) - www/npm is a meta port which depends on the default version (e.g. www/npm-node18) - www/yarn is a meta port which depends on the default version (e.g. www/yarn-node18) - Bump PORTREVISION of dependent ports for dependency change (from www/node16 to www/node18) Discussed with: jrm, otis, pizzamig
11 lines
406 B
Python
11 lines
406 B
Python
--- deps/openssl/openssl_no_asm.gypi.orig 2020-09-08 12:17:11 UTC
|
|
+++ deps/openssl/openssl_no_asm.gypi
|
|
@@ -48,7 +48,7 @@
|
|
'includes': ['config/archs/linux64-mips64/no-asm/openssl.gypi'],
|
|
}, {
|
|
# Other architectures don't use assembly
|
|
- 'includes': ['config/archs/linux-x86_64/no-asm/openssl.gypi'],
|
|
+ 'includes': ['config/archs/linux-elf/no-asm/openssl.gypi'],
|
|
}],
|
|
],
|
|
}
|