freebsd-ports/japanese/nethack34/files/patch-sys-unix-Makefile.utl
John Marino f715aadad7 Stage japanese/nethack34 and unbreak
* Update to the latest jnethack patch
 * Remove BROKEN flag
 * Add staging support (inspired by games/nethack)
 * Use base compiler instead of gcc
 * Quick fix for bug 192743 (chown and chmod)
 * marino: Use SUB_FILES instead of roll-your-own pkg-deinstall
 * marino: Remove unnecessary loop for REINPLACE_CMD
 * marino: Simplify docs installation, remove two loops
 * marino: Unmask configure commands
 * marino: Use parentheses and "&&" instead of just ";" on compounds
 * marino: Beef up pkg-descr for those unfamiliar with NetHack

PR:		193206
Submitted by:	WATANABE Kazuhiro
2014-09-06 17:19:47 +00:00

42 lines
1 KiB
Text

--- sys/unix/Makefile.utl.orig 2014-08-27 14:21:34.000000000 +0900
+++ sys/unix/Makefile.utl 2014-08-27 15:19:11.000000000 +0900
@@ -15,7 +15,7 @@
# if you are using gcc as your compiler,
# uncomment the CC definition below if it's not in your environment
-CC = gcc
+#CC = gcc
#
# For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
#
@@ -89,7 +89,17 @@
# flags for debugging:
# CFLAGS = -g -I../include
-CFLAGS = -O -I../include
+CFLAGS += -I../include
+ifeq ("$(GRAPHICS)","X11_GRAPHICS")
+CFLAGS += -DX11_GRAPHICS
+endif
+ifeq ("$(GRAPHICS)","QT_GRAPHICS")
+CFLAGS += -DQT_GRAPHICS
+endif
+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
+CFLAGS += -DGNOME_GRAPHICS
+endif
+
LFLAGS =
LIBS =
@@ -101,9 +111,9 @@
# yacc/lex programs to use to generate *_comp.h, *_lex.c, and *_yacc.c.
# if, instead of yacc/lex you have bison/flex, comment/uncomment the following.
-# YACC = yacc
+YACC = yacc
# LEX = lex
-YACC = bison -y
+# YACC = bison -y
# YACC = byacc
LEX = flex -8