2571ce9ac7
- Fixed assignment of PORTREVISION. It needs to be set before including bsd.port.pre.mk [1] - Disabled exit upon failure to kldunload and kldload of NVidia driver for 7667 driver. This would break an upgrade of an earlier install [1] - Fix PREFIX expansion in pkg-message PR: ports/82554 [1] Submitted by: Sean Farley <sean-freebsd(at)farley.org>
26 lines
546 B
Text
26 lines
546 B
Text
--- lib/Makefile.orig Mon Aug 16 17:05:30 2004
|
|
+++ lib/Makefile Mon Aug 16 17:07:47 2004
|
|
@@ -1,13 +1,19 @@
|
|
SUBDIR= libGL \
|
|
libnvidia-tls \
|
|
libGLcore \
|
|
- libXvMCNVIDIA \
|
|
- compat
|
|
+ libXvMCNVIDIA
|
|
|
|
-FIND_DIRS= /usr/lib ${X11BASE}/lib \
|
|
- /compat/linux/lib \
|
|
+.if !defined(WITHOUT_LINUX)
|
|
+SUBDIR+= compat
|
|
+.endif
|
|
+
|
|
+FIND_DIRS= /usr/lib ${X11BASE}/lib
|
|
+
|
|
+.if !defined(WITHOUT_LINUX)
|
|
+FIND_DIRS+= /compat/linux/lib \
|
|
/compat/linux/usr/lib \
|
|
/compat/linux/usr/X11R6/lib
|
|
+.endif
|
|
|
|
FIND_FILES!=(find ${FIND_DIRS} \
|
|
-name libGL.a\* -or \
|