ae52bc8089
http://library.gnome.org/misc/release-notes/2.26/ for a list of what's new. On the FreeBSD front, we introduced a port of libxul 1.9 as an alternative for Firefox 2.0 as a Gecko provider. Almost all of the Gecko consumers can make use of this provider by setting: WITH_GECKO=libxul The GNOME 2.26 port was done by ahze, kwm, marcus, and mezz with contributions by Joseph S. Atkinson, Peter Wemm, Eric L. Chen, Martin Matuska, Craig Butler, and Pawel Worach.
11 lines
739 B
Makefile
11 lines
739 B
Makefile
--- toolkit/mozapps/installer/packager.mk.orig 2007-09-26 13:45:01.000000000 -0400
|
|
+++ toolkit/mozapps/installer/packager.mk 2007-09-26 13:47:29.000000000 -0400
|
|
@@ -409,7 +409,7 @@
|
|
(cd $(DIST)/sdk/include && tar $(TAR_CREATE_FLAGS) - .) | \
|
|
(cd $(DESTDIR)$(includedir)/stable && tar -xf -)
|
|
# The dist/include has module subdirectories that we need to flatten
|
|
- find $(DIST)/include -xtype f -exec $(SYSINSTALL) $(IFLAGS1) {} $(DESTDIR)$(includedir)/unstable \;
|
|
+ find $(DIST)/include -type f -o -type l -exec $(SYSINSTALL) $(IFLAGS1) {} $(DESTDIR)$(includedir)/unstable \;
|
|
# IDL directory is stable (dist/sdk/idl) and unstable (dist/idl)
|
|
$(NSINSTALL) -D $(DESTDIR)$(idldir)/stable
|
|
$(NSINSTALL) -D $(DESTDIR)$(idldir)/unstable
|