freebsd-ports/databases/memcached/files/patch-configure.ac
Steve Wills 1eb32691d2 databases/memcached: update to 1.5.5
While here, re-generate patches.
2018-02-16 13:40:24 +00:00

21 lines
836 B
Text

--- configure.ac.orig 2017-12-21 06:24:20 UTC
+++ configure.ac
@@ -143,8 +143,7 @@ if test "x$enable_dtrace" = "xyes"; then
if test "x$DTRACE" != "xno"; then
AC_DEFINE([ENABLE_DTRACE],1,[Set to nonzero if you want to include DTRACE])
build_dtrace=yes
- # DTrace on MacOSX does not use -G option
- $DTRACE -G -o conftest.$$ -s memcached_dtrace.d 2>/dev/zero
+ /usr/bin/true
if test $? -eq 0
then
dtrace_instrument_obj=yes
@@ -627,7 +626,7 @@ then
elif test "$GCC" = "yes"
then
GCC_VERSION=`$CC -dumpversion`
- CFLAGS="$CFLAGS -Wall -Werror -pedantic -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
+ CFLAGS="$CFLAGS -Wall -pedantic -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
case $GCC_VERSION in
4.4.*)
CFLAGS="$CFLAGS -fno-strict-aliasing"