- Fix bug with NLS (thanks to kolter@freenode[weechat]) - Add new plugin language (ruby) - Add support of doing secure connection to irc server (gnutls) - Switch from PLIST to pkg-plist for better Makefile reading - Disabled plugin language LUA (if someone want it, just ask me)
47 lines
1.5 KiB
Text
47 lines
1.5 KiB
Text
--- configure.in.orig Thu May 25 02:46:22 2006
|
|
+++ configure.in Sat Jun 17 00:39:13 2006
|
|
@@ -537,6 +537,44 @@
|
|
fi
|
|
|
|
# ------------------------------------------------------------------------------
|
|
+# iconv
|
|
+# ------------------------------------------------------------------------------
|
|
+
|
|
+iconv_found="no"
|
|
+
|
|
+AC_CHECK_HEADER(iconv.h,ac_found_iconv_header="yes",ac_found_iconv_header="no")
|
|
+if test "x$ac_found_iconv_header" = "xyes" ; then
|
|
+ AC_CHECK_LIB(iconv,iconv_open,ac_found_iconv_lib="yes",ac_found_iconv_lib="no")
|
|
+ if test "x$ac_found_iconv_lib" = "xyes" ; then
|
|
+ LIBS="$LIBS -liconv"
|
|
+ fi
|
|
+ AC_MSG_CHECKING(for iconv usability in programs)
|
|
+ AC_TRY_RUN([
|
|
+ #include <iconv.h>
|
|
+ int main(int argc, char **argv) {
|
|
+ iconv_t conv = iconv_open("ISO8859-1", "UTF-8");
|
|
+ if (conv != (iconv_t) -1) {
|
|
+ return 0;
|
|
+ }
|
|
+ return 1;
|
|
+ }],iconv_found="yes")
|
|
+ if test "x$iconv_found" = "xno" ; then
|
|
+ AC_MSG_RESULT(no)
|
|
+ else
|
|
+ AC_MSG_RESULT(yes)
|
|
+ fi
|
|
+fi
|
|
+
|
|
+if test "x$iconv_found" = "xno" ; then
|
|
+ AC_MSG_ERROR([
|
|
+*** Iconv headers and/or libraries couldn't be found in your system.
|
|
+*** Try to install them with your software package manager.
|
|
+*** WeeChat can't be built without Iconv support.])
|
|
+fi
|
|
+
|
|
+
|
|
+
|
|
+# ------------------------------------------------------------------------------
|
|
# general vars
|
|
# ------------------------------------------------------------------------------
|
|
|