freebsd-ports/ftp/ncftp3/files/patch-ae
David E. O'Brien ff84ba4fea ELFify
1998-09-27 03:02:15 +00:00

11 lines
355 B
Text

--- libncftp/Makefile.in.orig Wed Nov 12 17:43:48 1997
+++ libncftp/Makefile.in Sat Sep 26 19:48:19 1998
@@ -55,7 +55,7 @@
$(LIBSO): $(SOBJS)
/bin/rm -f $(LIBSO) $(LIBSOS)
- gcc -shared -Wl,-soname,$(LIBSO) -o $(LIBSO) $(SOBJS)
+ $(CC) -shared -Wl,-x -o $(LIBSO) `lorder $(SOBJS) | tsort -q`
/bin/ln -s $(LIBSO) $(LIBSOS)
-@/bin/ls -l $(LIBSO)