freebsd-ports/audio/libnoise/files/patch-src_Makefile
Jeremy Messenger 789d75c728 -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a.
-Remove devel/libtool15 and devel/libltdl15.
-Fix ports build with libtool22/libltdl22.
-Bump ports that depend on libltdl22 due to shared library version change.
-Explain what to do update in the UPDATING.

It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop
and applications in the runtime.

With help:	marcus and kwm
Pointyhat-exp:	a few times by pav
Tested by:	pgollucci, "Romain Tartière" <romain@blogreen.org>, and
		a few MarcusCom CVS users. Also, I might have missed a few.
Repocopy by:	marcus
Approved by:	portmgr
2009-08-02 19:36:34 +00:00

19 lines
758 B
Text

--- src/Makefile.orig 2004-10-24 21:21:12.000000000 +0200
+++ src/Makefile 2009-07-16 11:31:48.000000000 +0200
@@ -12,12 +12,12 @@
# hooks for future makefiles being able to make multiple SOs, or older SOs
libnoise: libnoise.so libnoise.a libnoise.la
-libnoise.so: libnoise.so.0
-libnoise.so.0: libnoise.so.0.3
+#libnoise.so: libnoise.so.0
+#libnoise.so.0: libnoise.so.0.3
# Real build targets
-libnoise.so.0.3: $(OBJECTS)
- $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -shared -Wl,-soname=libnoise.so.0 -o $@ $(OBJECTS:.o=.lo)
+libnoise: $(OBJECTS)
+ $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -shared -o $@.la $(OBJECTS:.o=.lo) -rpath %%LOCALBASE%%/lib
libnoise.a: $(OBJECTS)
$(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -o $@ $(OBJECTS)