freebsd-ports/astro/roadmap/files/patch-gtk-Makefile
Pav Lucistnik 8294db3dfd - Update to 1.0.6
PR:		ports/66903 (based on)
Submitted by:	Roman Neuhauser <neuhauser@chello.cz>
Approved by:	maintainer timeout (2 weeks)
2004-06-06 22:43:49 +00:00

67 lines
1.8 KiB
Text

--- src/gtk/Makefile.orig Tue May 25 07:28:15 2004
+++ src/gtk/Makefile Mon Jun 7 00:25:58 2004
@@ -1,12 +1,12 @@
-GUICFLAGS=`gtk-config --cflags`
-GUILDFLAGS=`gtk-config --libs`
+GUICFLAGS=`${GTK_CONFIG} --cflags`
+GUILDFLAGS=`${GTK_CONFIG} --libs`
-STDCFLAGS=-O2 -ffast-math -fomit-frame-pointer -g -Wall
+STDCFLAGS=-ffast-math -fomit-frame-pointer -Wall -I${LOCALBASE}/include
# STDCFLAGS=-g -Wall -DROADMAP_DEBUG_HEAP
# STDCFLAGS=-g -Wall -pg -fprofile-arcs -g
-CFLAGS=$(STDCFLAGS) $(GUICFLAGS) -I..
+CFLAGS+=$(STDCFLAGS) $(GUICFLAGS) -I..
RDMLIBS= ../libroadmap.a libgtkroadmap.a ../unix/libosroadmap.a ../libroadmap.a
LIBS=$(RDMLIBS) $(GUILDFLAGS) -lm
@@ -24,7 +24,7 @@
RUNTIME=gtkroadgps gtkroadmap
-INSTALLDIR=/usr/local
+INSTALLDIR=${LOCALBASE}
# --- Conventional targets ----------------------------------------
@@ -32,23 +32,23 @@
all: runtime
others:
- make -C .. CFLAGS="$(STDCFLAGS)" runtime
- make -C .. -C unix CFLAGS="$(STDCFLAGS) -I.." runtime
+ ${MAKE} -C .. CFLAGS="$(STDCFLAGS)" runtime
+ ${MAKE} -C .. -C unix CFLAGS="$(STDCFLAGS) -I.." runtime
build:
- make -C .. CFLAGS="$(STDCFLAGS)" build
+ ${MAKE} -C .. CFLAGS="$(STDCFLAGS)" build
runtime: others $(RUNTIME)
clean: cleanone
- make -C .. cleanone
- make -C .. -C unix cleanone
+ ${MAKE} -C .. cleanone
+ ${MAKE} -C .. -C unix cleanone
cleanone:
rm -f *.o *.a *.da $(RUNTIME)
install: all
- make -C .. install
+ ${MAKE} -C .. install
cd $(INSTALLDIR)/bin; rm -f $(RUNTIME) roadmap roadgps
cp $(RUNTIME) $(INSTALLDIR)/bin
ln -s $(INSTALLDIR)/bin/gtkroadmap $(INSTALLDIR)/bin/roadmap
@@ -57,7 +57,7 @@
uninstall:
cd $(INSTALLDIR)/bin ; rm -f $(RUNTIME) roadmap roadgps
- make -C .. uninstall
+ ${MAKE} -C .. uninstall
# --- The real targets --------------------------------------------