4c345ed272
- Use Makefile for building instead of scons, and remove Perl dependency. - Use pkg-plist. - Add OPTIONS. Allow to build without X11, threaded version, etc. - Fix building on non-i386 and FreeBSD 4.X. - Respect CFLAGS when optimizations are enabled. - Add patch to fix 2 security vulnerabilities [1]. PR: ports/98295 Submitted by: alepulver (myself) Approved by: maintainer (timeout) Obtained from: q3icculus (http://icculus.org/quake3/) [1] Security: CVE-2006-2082 [1]
11 lines
353 B
C
11 lines
353 B
C
--- ./code/q3_ui/ui_playermodel.c.orig Wed May 31 20:52:07 2006
|
|
+++ ./code/q3_ui/ui_playermodel.c Wed May 31 20:54:50 2006
|
|
@@ -404,7 +404,7 @@
|
|
{
|
|
filelen = strlen(fileptr);
|
|
|
|
- COM_StripExtension(fileptr,skinname);
|
|
+ COM_StripExtension(fileptr, skinname, sizeof(skinname));
|
|
|
|
// look for icon_????
|
|
if (!Q_stricmpn(skinname,"icon_",5))
|