freebsd-ports/lang/php5/files/patch-pear::Makefile.frag
Alex Dupre ac9bdc26ef - Add sysvmsg extension [1]
- Add XML_RPC to PEAR bootstrap [2]
- Use the official pcre fix [3]
- Bump PORTREVISION

Requested by:	Andy Smith <andy@strugglers.net> [1]
Submitted by:	thierry [2]
Obtained from:	php CVS [3]
2004-05-07 23:30:30 +00:00

35 lines
1.4 KiB
Makefile

--- pear/Makefile.frag.orig Tue Sep 2 03:30:13 2003
+++ pear/Makefile.frag Thu Apr 22 23:52:40 2004
@@ -1,6 +1,7 @@
# -*- makefile -*-
peardir=$(PEAR_INSTALLDIR)
+XML_RPC_ver=1.1.0
# Skip all php.ini files altogether
PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0
@@ -13,10 +14,18 @@
install-pear:
@echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
- @if $(mkinstalldirs) $(INSTALL_ROOT)$(peardir); then \
- $(MAKE) -s install-pear-installer install-pear-packages; \
- else \
- cat $(srcdir)/install-pear.txt; \
- exit 5; \
- fi
+ @$(mkinstalldirs) $(INSTALL_ROOT)$(peardir)/bootstrap \
+ $(INSTALL_ROOT)$(peardir)/bootstrap/Archive \
+ $(INSTALL_ROOT)$(peardir)/bootstrap/Console \
+ $(INSTALL_ROOT)$(peardir)/bootstrap/XML \
+ $(INSTALL_ROOT)$(peardir)/bootstrap/XML/RPC
+ @cp $(srcdir)/PEAR.php $(srcdir)/System.php \
+ $(INSTALL_ROOT)$(peardir)/bootstrap
+ @cp $(srcdir)/Archive/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Archive
+ @cp $(srcdir)/Console/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Console
+ @cp -R $(srcdir)/OS $(INSTALL_ROOT)$(peardir)/bootstrap
+ @cp -R $(srcdir)/PEAR $(INSTALL_ROOT)$(peardir)/bootstrap
+ @tar xf $(srcdir)/packages/XML_RPC-$(XML_RPC_ver).tar
+ @cp XML_RPC-$(XML_RPC_ver)/RPC.php $(INSTALL_ROOT)$(peardir)/bootstrap/XML
+ @cp XML_RPC-$(XML_RPC_ver)/Server.php $(INSTALL_ROOT)$(peardir)/bootstrap/XML/RPC