8937ed4066
The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
75 lines
1.7 KiB
Text
75 lines
1.7 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./ell/m2c/Makefile Tue Feb 15 14:22:40 1994
|
|
+++ ./ell/m2c/Makefile Thu Aug 5 18:48:53 2004
|
|
@@ -1,37 +1,27 @@
|
|
-BIN = $(HOME)/bin
|
|
-LIB = $(HOME)/lib
|
|
-OPT = -O
|
|
-CC = cc
|
|
+.include "../../Makefile.inc"
|
|
|
|
- # C library (reuse)
|
|
-REUSE = ../../reuse/m2c
|
|
-
|
|
- # C library (common)
|
|
-COMMON = ../../common/m2c
|
|
-
|
|
- # C libraries
|
|
-CLIBS = $(COMMON)/libcommon.a $(REUSE)/libreuse.a
|
|
-
|
|
- # options for C compiler
|
|
-CFLAGS = -w -I$(COMMON) -I$(REUSE) $(OPT)
|
|
-
|
|
-M2FLAGS = -c
|
|
+ROOTDIR = ../..
|
|
+CFLAGS += -I$(COMMONINC) -I$(INCDIR)
|
|
+CLIBS += $(COMMONLIB) $(REUSELIB)
|
|
|
|
all : ell
|
|
|
|
-install: ell ell.sh $(LIB)/ell
|
|
- if test $(LIB) = $(BIN); then echo error: BIN = LIB; false; else true; fi
|
|
- sed "s;LIB;$(LIB);" < ell.sh > $(BIN)/ell
|
|
- chmod a+rx $(BIN)/ell
|
|
- install -c -s -m 755 ell $(LIB)/ell
|
|
- install -c -m 644 ErrorTab $(LIB)/ell
|
|
+install: ell ell.sh $(DESTLIB)/ell
|
|
+ if test $(DESTLIB) = $(DESTBIN); then echo error: DESTBIN = DESTLIB; false; else true; fi
|
|
+ sed "s;LIB;$(DESTLIB);" < ell.sh > $(DESTBIN)/ell
|
|
+ chmod a+rx $(DESTBIN)/ell
|
|
+ install -c -s -m 755 ell $(DESTLIB)/ell
|
|
+ install -c -m 644 ErrorTab $(DESTLIB)/ell
|
|
|
|
# installation directories
|
|
|
|
-$(LIB)/ell: $(LIB)
|
|
- sh -c "if test ! -d $(LIB)/ell; then mkdir -p $(LIB)/ell; else true; fi"
|
|
+$(DESTLIB)/ell: $(DESTLIB)
|
|
+ sh -c "if test ! -d $(DESTLIB)/ell; then mkdir -p $(DESTLIB)/ell; else true; fi"
|
|
|
|
-# SYSTEM_ = SYSTEM_.o
|
|
+clean:
|
|
+ -rm -f $(STDCLEAN)
|
|
+ -rm -f *.o
|
|
+ -rm -f ell
|
|
|
|
# HEAD
|
|
|
|
@@ -239,18 +229,3 @@
|
|
CodeC.o \
|
|
$(CLIBS)
|
|
|
|
-# TAIL
|
|
-
|
|
-clean :
|
|
- rm -f core *.o
|
|
-
|
|
-.SUFFIXES: .md .mi .h .c .o
|
|
-
|
|
-.mi.c:
|
|
- mtc2 $(M2FLAGS) $*.mi;
|
|
-
|
|
-.md.h:
|
|
- mtc2 $(M2FLAGS) $*.md;
|
|
-
|
|
-.c.o:
|
|
- $(CC) $(CFLAGS) -c $*.c
|