8937ed4066
The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
83 lines
1.7 KiB
Text
83 lines
1.7 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./l2cg/m2c/Makefile Tue Feb 15 14:23:40 1994
|
|
+++ ./l2cg/m2c/Makefile Thu Aug 5 18:49:08 2004
|
|
@@ -1,42 +1,32 @@
|
|
-BIN = $(HOME)/bin
|
|
-LIB = $(HOME)/lib
|
|
-OPT = -O
|
|
-CC = cc
|
|
|
|
- # C library (reuse)
|
|
-REUSE = ../../reuse/m2c
|
|
+.include "../../Makefile.inc"
|
|
|
|
- # C libraries
|
|
-CLIBS = $(REUSE)/libreuse.a
|
|
+ROOTDIR = ../..
|
|
+CFLAGS += -I$(INCDIR)
|
|
+CLIBS += $(REUSELIB)
|
|
+
|
|
+all: l2cg
|
|
+
|
|
+install: l2cg l2cg.sh $(DESTLIB)/l2cg
|
|
+ if test $(DESTLIB) = $(DESTBIN); then echo error: DESTBIN = DESTLIB; false; else true; fi
|
|
+ sed 's;LIB;$(DESTLIB);g' < l2cg.sh > $(DESTBIN)/l2cg
|
|
+ chmod a+rx $(DESTBIN)/l2cg
|
|
+ install -c -s -m 755 l2cg $(DESTLIB)/l2cg
|
|
|
|
- # options for C compiler
|
|
-CFLAGS = -w -I$(REUSE) $(OPT)
|
|
-
|
|
-M2FLAGS = -c -d$(HOME)/reuse/src
|
|
-
|
|
-
|
|
-all : l2cg
|
|
-
|
|
-install: l2cg l2cg.sh $(LIB)/l2cg
|
|
- if test $(LIB) = $(BIN); then echo error: BIN = LIB; false; else true; fi
|
|
- sed 's;LIB;$(LIB);g' < l2cg.sh > $(BIN)/l2cg
|
|
- chmod a+rx $(BIN)/l2cg
|
|
- install -c -s -m 755 l2cg $(LIB)/l2cg
|
|
-
|
|
-# installation directories
|
|
-
|
|
-$(LIB)/l2cg: $(LIB)
|
|
- sh -c "if test ! -d $(LIB)/l2cg; then mkdir -p $(LIB)/l2cg; else true; fi"
|
|
-
|
|
-# SYSTEM_ = SYSTEM_.o
|
|
+$(DESTLIB)/l2cg: $(DESTLIB)
|
|
+ sh -c "if test ! -d $(DESTLIB)/l2cg; then mkdir -p $(DESTLIB)/l2cg; else true; fi"
|
|
|
|
lint:
|
|
lint -I$(REUSE) *.c
|
|
|
|
l2cg: ParserDrv
|
|
- mv ParserDrv l2cg
|
|
+ cp ParserDrv l2cg
|
|
|
|
|
|
+clean:
|
|
+ -rm -f $(STDCLEAN)
|
|
+ -rm -f *.o l2cg ParserDrv
|
|
+
|
|
# HEAD
|
|
|
|
sources : Parser.h
|
|
@@ -68,18 +58,3 @@
|
|
Scanner.o \
|
|
$(CLIBS)
|
|
|
|
-# TAIL
|
|
-
|
|
-clean :
|
|
- rm -f core *.o l2cg
|
|
-
|
|
-.SUFFIXES: .md .mi .h .c .o
|
|
-
|
|
-.mi.c:
|
|
- mtc2 $(M2FLAGS) $*.mi;
|
|
-
|
|
-.md.h:
|
|
- mtc2 $(M2FLAGS) $*.md;
|
|
-
|
|
-.c.o:
|
|
- $(CC) $(CFLAGS) -c $*.c
|