8937ed4066
The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
46 lines
1.2 KiB
Text
46 lines
1.2 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./specs/c/sather/Makefile Tue Feb 15 14:28:38 1994
|
|
+++ ./specs/c/sather/Makefile Wed Aug 25 12:03:39 2004
|
|
@@ -1,22 +1,22 @@
|
|
-LIB = $(HOME)/lib
|
|
-INCDIR = $(LIB)/include
|
|
-CFLAGS = -I$(INCDIR)
|
|
-CC = cc
|
|
+ROOTDIR= ../../..
|
|
+.include "../../Makefile.inc"
|
|
+
|
|
+CFLAGS = $(TCFLAGS) -I $(TMPINC)
|
|
|
|
ParserDrv: ParserDrv.o Scanner.o Parser.o
|
|
- $(CC) $(CFLAGS) ParserDrv.o Scanner.o Parser.o $(LIB)/libreuse.a -o ParserDrv
|
|
+ $(CC) $(CFLAGS) ParserDrv.o Scanner.o Parser.o -L $(TMPLIB) -l reuse -o ParserDrv
|
|
|
|
Scanner.rpp Parser.lalr: sather.pars
|
|
- lpp -cxzj sather.pars;
|
|
+ $(LPP) -cxzj sather.pars;
|
|
|
|
sather.rex: sather.scan Scanner.rpp
|
|
- rpp < sather.scan > sather.rex;
|
|
+ $(RPP) < sather.scan > sather.rex;
|
|
|
|
Scanner.h Scanner.c: sather.rex
|
|
- rex -cd sather.rex;
|
|
+ $(REX) -cd sather.rex;
|
|
|
|
Parser.h Parser.c ParserDrv.c: Parser.lalr
|
|
- lalr -c -d -p Parser.lalr;
|
|
+ $(LALR) -c -d -p Parser.lalr;
|
|
|
|
ParserDrv.o: Parser.h Scanner.h
|
|
Parser.o: Parser.h Scanner.h
|
|
@@ -26,9 +26,6 @@
|
|
lint $(CFLAGS) -b -u *.c
|
|
|
|
clean:
|
|
- rm -f core *.[hco] _Debug ParserDrv sather.rex Parser.lalr Scanner.rpp
|
|
-
|
|
-.SUFFIXES: .c .o
|
|
+ -rm -f $(STDCLEAN)
|
|
+ -rm -f *.[hco] _Debug ParserDrv sather.rex Parser.lalr Scanner.rpp
|
|
|
|
-.c.o:
|
|
- $(CC) $(CFLAGS) -c $*.c
|